Support » Plugin: Easy Theme and Plugin Upgrades » Not updating

  • balticsamurai

    (@balticsamurai)


    Love your plugin. It was working all fine. Now, when I update a plugin, I still see the ‘old’ version after the update. Any ideas why so?

    Also, I noticed it hasn’t been updated for a while. Would be awesome if you could keep it updated, Chris. Many would appreciate!
    Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Chris Jean

    (@chrisjean)

    Can you clarify what you mean by seeing the old version after update? I can think of two different ways to interpret this:

    1) Your plugin is named “Example Plugin”. After updating, you see two “Example Plugin” plugins listed on the Plugins page. One with the old version number and one with the new version number.

    2) The old version of the plugin is “1.0.0”. You tried updating to version “2.0.0”. Despite the updating looking like it worked properly, the Plugins page still shows the plugin as having version “1.0.0”.

    Which of those two is the issue that you are seeing? Or is the issue something different?

    balticsamurai

    (@balticsamurai)

    Chris, thanks for your prompt reply. Version 2. No errors, nothing all seems fine in the process but plugins show the same (e.g. 1.0.0 as in your example) version as before. Again, love your plugin – very helpful 😉

    Plugin Author Chris Jean

    (@chrisjean)

    With the second option being the issue, I can think of two possibilities:

    1) The plugin version number was not updated properly when the zip file was created. In other words, the plugin is updating just fine, but the plugin in the zip file still has the old version number.

    2) There is some type of new compatibility issue with your site and the Easy Theme and Plugin Upgrades plugin. I say new issue since you indicate that it was working before.

    I’ve seen #1 many times before. It’s a simple thing to accidentally forget to update the version number before shipping out a plugin update.

    The least-technical way to test for #1 is to manually update the plugin (use FTP to remove the old plugin directory and install the plugin zip file as normal). If the version stays the same after updating, the plugin zip file is the issue and you need to contact the plugin developer to ask for a new zip file that has the proper version number.

    Try manually updating and let me know the results.

    Chris, thanks for your update. I’ll give it a try.

    Hi Chris,

    If this plugin works perfectly, perhaps you should change an image or css rule a little and slap on a new version number to show that you are keeping the plugin up to date and are supporting it.

    Thanks for your great work.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.