Support » Installing WordPress » Not understanding things…

  • Hi. If I’m missing some documentation, please, by all means, point me to it. All I can find is the five-minute installation, which does me no good, and the FAQ, which doesn’t help either. I’ve searched the forum and either haven’t found or haven’t understood if I have the same problem. I’m a graphic designer, so I’m new to PHP and SQL, so most of this seems pretty over my head…
    My problem is this: I can’t get wp to see the database. Not sure if I did this correctly, but here’s what I did:
    I modified the wp-config.php file to fit my settings. A screenshot of my config file can be located here.
    Then I uploaded the whole wordpress folder to \public_html\wordpress\. I chmod’ed the wp-admin folder and my wp-config.php file to prohibit public access, although for the record I get the same problems even with the default permissions.
    I made a new sql database from the ‘control panel’ my hoster gives me. What I did can be seen here. As you can see, I created a sql database called nokicat_blog. I then created user nokicat_wp and gave it full priveliges for database nokicat_blog. I also went into phpMyAdmin (here and here are the two frames from the page; the index page didn’t work) to see if everything was configured correctly, and everything appears to be… The Linux server runs PHP 4.3.8 and mySQL 4.0.20-standard. Everything is configured for localhost, as you can see, and I know the password is correct. Are my folders in the wrong places?
    And, as a result of this, I get to see this. Also, I just realized I had to give public access again to wp-config.php in order to make it work, so how on earth can you keep the password private? Am I crazy, or is there just no documentation anywhere about this? If there is, point me to it, I will gladly read it instead of wasting forum time.
    Thanks,
    Ryan

Viewing 12 replies - 1 through 12 (of 12 total)
  • try dropping the chmod on wp-admin as well. if you try to get to wp-config.php you’ll see that your password is safe. also.. i see no mention of running the install file. did you do that?

    Yes, running the install file gives me the same screen. Also, currently, no permissions are restricted. Try it yourself: http://www.nokicat.com/wordpress/wp-admin/install.php

    Have you added the user to the database ?
    http://wiki.wordpress.org/Cpanel

    Yes, didn’t you read my post and check out the links??!!

    Ryan I checked out the links you gave, especially this one:
    http://www.nokicat.com/install-issues/sql/
    but strangely enough I cannot see a button that would say “Add user to db”. And as it is NOW (i.e. when you put up the link) the user and the database are not connected.
    Click here to see a snapshot of my DB admin panel.
    1. It has to show which user is “added” to the db
    2. It has to show the connection strings
    3. There should be a button saying Add user to db (and before that you can select user and db from the drop-down menu, if you have more…)
    4. Even if I created now – for illustration purposes – a “testuse(r)”, it is NOT connected to the db, unless I select it and click on the “Add user…” button.
    Hope this helps…

    Moshu,
    Thanks! It worked. If you look at my screenshot again (it hasn’t changed), to me it appeared to have granted nokicat_wp permissions, but in actuality, I hadn’t. I got the connection strings as well. Fundamentally all the control panels are the same, because aside from the gui, mine is exactly like yours with the user being granted permissions.
    Thanks a lot,
    Ryan
    (btw I would still be interested in knowing what permissions I should & shouldn’t have on the folders)

    So I guess Podz was right; no surprise there.
    Default permissions on the folders is fine.

    Thanks, Nuclear Moose, for that stunningly brilliant post. If the purpose of forums to be helpful, neither you nor pods have shown any amount of usefulness.

    papaskunk: You certainly chose a fitting nickname. For the record, Podz did direct you to a page that had the solution to your problem. Your aggressive attitude is entirely uncalled for.

    I too am facing this problem. I had successfully installed WP a few days back. It was working till saturday. When I visited my site today, I got the connection error message. I check in CPanel server status and MySql is working. I check using phpMyAdmin and again I was able to browse the database. I tried removing and then adding the user again. Still the wp installation would not work.
    I have also tried to reinstall the same after deleting the database as well as the user. Then created fresh database with a different name, different user, and added the user to the database with all permissions. Then copied all the files afresh to the server.
    Tried installing and again no luck. Could it be something to do with MySQL which I isee is 4.0.20-standard as in the first post ?

    Why am I being shown as Anon in the last post when I had logged in on the first page ?

    Sorry for jumping the gun! My host seemed to have had some problem. The site is now working.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.