WordPress.org

Support

Support » Plugins and Hacks » WP to Twitter » [Resolved] Not Tweeting Custom Posts

[Resolved] Not Tweeting Custom Posts

  • I’ve used this plugin successfully in the past, however on a new site I’ve just built I can only seem to get the plugin to tweet default posts and not custom ones, despite having set my options so that it tweets links to default posts as well as the 2 custom post types I’ve set up.

    Has anyone else had this issue?

    http://wordpress.org/plugins/wp-to-twitter/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Joe Dolson

    @joedolson

    I can’t reproduce this, and don’t have any other reports of it. What is creating your custom post types? Is it something you’ve used successfully before?

    pealo86

    @pealo86

    Hi,
    I’m using the following code to create 2 custom post types:

    // register custom posts
    add_action( 'init', 'create_post_type' );
    function create_post_type() {
    
      register_post_type( 'beauty-salon',
        array(
      	'labels' => array(
      	  'name' => __( 'Beauty Salons' ),
      	  'singular_name' => __( 'Beauty Salon' ),
      	  'add_new_item' => __( 'Add New Beauty Salon' ),
      	  'edit_item' => __( 'Edit Beauty Salon' ),
      	  'new_item' => __( 'New Beauty Salon' ),
      	  'view_item' => __( 'View Beauty Salon' ),
      	  'search_items' => __( 'Search Beauty Salons' )
      	),
      	'public' => true,
      	'exclude_from_search' => true,
      	'menu_position' => 5,
      	'supports' => array('title', 'editor', 'thumbnail', 'comments', 'author')
        )
      );
    
      register_post_type( 'job-course',
        array(
      	'labels' => array(
      	  'name' => __( 'Jobs & Courses' ),
      	  'singular_name' => __( 'Job / Course' ),
      	  'add_new_item' => __( 'Add New Job / Course' ),
      	  'edit_item' => __( 'Edit Job / Course' ),
      	  'new_item' => __( 'New Job / Course' ),
      	  'view_item' => __( 'View Job / Course' ),
      	  'search_items' => __( 'Search Jobs & Courses' )
      	),
      	'public' => true,
      	'exclude_from_search' => true,
      	'menu_position' => 6,
      	'supports' => array('title', 'editor', 'author'),
      	'taxonomies' => array('listing-type')
        )
      );
    
    }

    Could it be down to me excluding them from search by any chance?

    Plugin Author Joe Dolson

    @joedolson

    That seems pretty standard. Can you submit a support request using the built in support form?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Not Tweeting Custom Posts’ is closed to new replies.
Skip to toolbar