Support » Plugin: Multisite User Sync » not syncing on role change

  • hi,

    your plugin works when activated on users that are already members, but when new members sign up and pay for their subscription the role changes on main site of multisite but not on another site on multisite.

    I also have yith role changer plugin activated for woo commerce.

    If I network deactivate your plugin and then reactivate it the roles change but they don’t change if another user joins when the plugin is active.

    Seems like it is not activating and changing roles unless I deactivate the plugin and reactivate it. Only once for all users that are current members.

    any idea what it might be?

    thanks

    Jim

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Shamim Hasan

    (@shamim51)

    Is this plugin network activated?
    When user pay for their subscription, user wordpress role changes?
    If you add a user manually, does that user added to all sub sites? If you change role of that user, does that changes in all sub sites?

    I have tried it network activated and activated on both sites

    When user pays the role changes on site A, but not on Site B.

    I tried changing the role at network level a few times and Site A updated but Site B was always a level behind. I changed a user to Subsriber from Customer and result was:
    Site A = Subscriber
    Site B = Customer

    I then changed from Subscriber to Editor, result was:
    Site A = Editor
    Site B = Subscriber

    I then changed from Editor to Author, result was:
    Site A = Author
    Site B = Editor

    Seems site B always stays a level behind.

    Does that make sense?

    Jim

    Plugin Author Shamim Hasan

    (@shamim51)

    I have tested with this plugin network activated. Each time i change a role to any site, It sync to all sites.

    Can you deactivate all other plugins and change theme to one of default theme and test?

    Let me know.

    jimwise68

    (@jimwise68)

    Hi, it seems that “YITH Automatic Role Changer for WooCommerce” plugin is causing the issue.

    Is this something you have come across before?

    Is there a way round it?

    thanks

    Jim

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘not syncing on role change’ is closed to new replies.