Support » Fixing WordPress » Not sure what I messed up, but really in a pickle

  • Resolved disneymadesimple

    (@disneymadesimple)


    I recently moved my site from http://disneymadesimple.com/wordpress to the root directory following the instructions in the codex. After the transfer everything worked fine, except I noticed some of the permalinks weren’t updating.

    I was messing around with the .htaccess file according to some forum posts as well as just generally poking around.

    Well I screwed something up because my whole site is messed up. I can’t login and the pages look like they were made in a text editor.

    Please help!! Let me know whatever info you need, I’ll get it to you.

    I just relaunched my site and I’m so frazzled, I don’t know what to do to fix this.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Use FTP or host provided file management tool to delete or better rename that .htaccess file to .htaccess.bak and then log into site and re-save permalinks. A new .htaccess file will be written to root – if not, an error message will display on permalinks setting page. You can create the file manually following this:

    http://codex.wordpress.org/htaccess

    easy question, but are you sure you moved all the files from your /wordpress to the root? Im seeing 67 missing files, scripts, images, etc. All theme and WP core based.

    you may want to just deactivate your htaccess file (remove the . on the file name) to see if that helps clear up any redirects you may have.

    This is the codex article I used to move my site to root: http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    I’ve used this before on a few other sites and never had a problem. I followed the instructions to the letter. @matt adams: Shouldn’t WordPress be looking for those missing files in the subdirectory?

    Which .htaccess file should I be messing with? The one in the root or the one in the subdirectory?

    My .htaccess file looks like this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    @Pinoneer Valley Web Design When I rename the root .htaccess file and try to login, all I get is a blank screen…did I do something wrong?

    I recently moved my site from //disneymadesimple.com/wordpress to the root directory following the instructions in the codex.

    Giving WordPress it’s own Directory is the opposite of moving from a directory to root.

    First, consult with web host that your domain is pointing to root folder. If it is, then change the site URL manually and try to login again. As a test rename the wordpress folder to old-wordpress and remove both .htaccess files too (per above).

    Okay, so I changed the site url manually and when I put them both to http://disneymadesimple.com/wordpress it worked! I’m able to login and my site looks fine.

    THANK YOU SO MUCH.

    Now, in order to do what I was originally trying to do, which is have wordpress live in the subdirectory and point the site to the root, do I just follow the original steps? Should I still delete both .htaccess files?

    I cannot thank you enough for your help, you saved me from pulling my hair out!!

    Now, my site seems to be in both places, the root and the subdirectory. Is that bad?

    Now, my site seems to be in both places, the root and the subdirectory. Is that bad?

    Not what you intended, eh? What you just did was make the root site point to the /wordpress site.

    First, since http://disneymadesimple.com/wordpress is working now. remove all of the WordPress files in the ROOT (please back them up with FTP first). and then follow these steps to the letter:

    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory#Using_a_pre-existing_subdirectory_install

    Okay. In the steps where it says to change the site address url in the general settings panel, should I change it in the wp-config file instead? Since manually updating the config file it doesn’t let me change the urls in the settings panel.

    So I tried it. I edited the config file to the tutorials specifications, followed all the other instructions to the letter and had the same issue as before. Site looks all weird. Changed the config file back to subdirectory (both urls) and it worked again.

    Should my root .htaccess file look like this?

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>

    # END WordPress

    the site URL is not in the config, only the database settings, which you wont need to change.

    your root htaccess should look like this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Per the instructions here:
    http://codex.wordpress.org/Moving_WordPress

    1. Log in to your blog.
    2. Go to the Administration > Settings > General panel.
    3. In the box for WordPress address (URI): change the address to the new location of your main WordPress core files.
    4. In the box for Site address (URL): change the address to the new location, which should match the WordPress (your public site) address (URI).
    5. Click Save Changes.
      (Do not try to open/view your blog now!)
    6. Move your WordPress core files to the new location. This includes the files found within the original directory, such as http://example.com/wordpress, and all the sub-directories, to the new location.
    7. Now, try to open your site by going to yourdomain.com/wp-admin. Note, you may need to go to yourdomain.com/wp-login.php
    8. If you are using Permalinks, go to the Administration > Settings > Permalinks panel and update your Permalink structure to your .htaccess file, which should be in the same directory as the main index.php file.

    which is have wordpress live in the subdirectory and point the site to the root,

    @matt, the OP clarified that she wants the site files to reside in a sub and resolve to the main domain name…Hence my notes now above…

    @disneymadesimple, where does it say to edit wp-config.php in my last link? read only these instructions:

    Using a pre-existing subdirectory install

    What the info section does not note is to not have a fully running site already at root, which is why I said to back those up (make sure you do this just in case) and remove them from the root folder prior to performing the steps in my last link (repeated here).

    @pioneer, I edited the config file because I cannot edit the site urls in general settings anymore like the tutorial says, because I followed your advice and used this tutorial http://codex.wordpress.org/Changing_The_Site_URL to change the site url when I couldn’t gain access at all.

    When I followed the steps for using a pre-existing subdirectory install, I did remove all files running at root, just like you said.

    However, I will try again, maybe a overlooked something…

    Thank you again for sticking with me, your help is truly appreciated!!

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Not sure what I messed up, but really in a pickle’ is closed to new replies.