WordPress.org

Support

Support » Plugins and Hacks » WordPress-to-lead for Salesforce CRM » [Resolved] Not submitting form – no success message

[Resolved] Not submitting form – no success message

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Nick Ciske

    @nickciske

    Unfortunately, I can’t diagnose what I can’t see — can you provide a link to the form in question?

    Sure – the page is still a work in progress but try this,

    http://musonisystem.com/test/

    Plugin Author Nick Ciske

    @nickciske

    So… looks like you may have WPCF7 CSS integration checked… and some kind of ajax submit thing happening with WPCF7?

    Can you tell me which WPCF7 plugins you have installed?

    The plugin does not support ajax submits at this time — which is likely the problem.

    e.g. I think the SF submit button is getting hijacked by something in WPCF7 due to the CSS classes — which is trying to submit the form via ajax … to some endpoint that never returns a response.

    Turning off the WPCF7 CSS integration should fix it — if it does, let me know which plugins are involved and I can see if there’s a workaround.

    Hi,

    I turned off the WPCF7 checkbox and that did the trick thanks – form submitted successfully.

    In terms of the other plugins installed at the time, I’m not sure which one might be doing the damage, but:

    Broken Link Checker
    Contact Form 7
    Disable Comments
    Twitter Widget Pro
    Woo Commerce
    WordPress Importer
    Wordpress SEO

    Thanks for the fix!

    Plugin Author Nick Ciske

    @nickciske

    Must be something new (or a setting) in WPCF7.

    Plugin Author Nick Ciske

    @nickciske

    Will try to have a fix or workaround for this in 2.3.

    Thanks again

    I was thrilled to install this but can’t seem to get the form to submit either. I have tried turning CAPTCHA on and off and have also tried using the WPCF7 or the default CSS. Could having Contact Form 7 installed on site be causing a conflict?

    Forgot to add that here is the test page after I submit. Have tried to put the short code on a stand-alone page and in the widget area and get no response in either location.

    http://oceanstatesoftware.com/contact-us/#salesforce_w2l_lead_1

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Not submitting form – no success message’ is closed to new replies.
Skip to toolbar