Support » Plugin: WordPress Zero Spam » Not stopping Gravity Form spam anymore

  • Resolved David Waumsley

    (@waumsley)


    I updated to 4.3.9, but since version 4 it does not seem to be stopping Gravity Forms spam. Some of that was due to the error cause the plugin to deactivate on (around 60) client sites. Then I realized I had to go back and tick on the box for Gravity Forms, but still even after the latest update spam is getting in. It used be zero spam.

Viewing 6 replies - 1 through 6 (of 6 total)
  • I am also having this issue. For me, it seems that after the most recent updates the checkbox ‘Verify Gravity Forms Submissions’ was disabled.

    Not sure if that helps in the short term, or the issue is wider?

    This is happening on multiple websites that I run where that checkbox has been disabled in recent updates – which is obviously an issue and one that the developers can hopefully clarify?

    Plugin Author Ben Marshall

    (@bmarshall511)

    See https://github.com/bmarshall511/wordpress-zero-spam/issues/192

    v4 was a complete rewrite of the plugin & why it got disabled when upgrading to v4. 2 days ago, the patch referenced above was released so that by default, if you had a plugin that Zero Spam supports, it would be enabled.

    As for the spam you’re getting, can you provide more details? What makes you think it’s a spam bot vs. a spammy user submitting the form? What page is this happening on?

    The more details the better so I can reproduce & fix. Otherwise, it’s like taking your car to the shop saying there’s a weird sound, but when you get it there, nothing happens. Can’t fix what I can’t reproduce.

    Feel free to submit bugs/feature requests here to track the progress: https://github.com/bmarshall511/wordpress-zero-spam/issues

    Plugin Author Ben Marshall

    (@bmarshall511)

    I just pushed a fix for a GF issue some people were seeing (v4.4.1). Hopefully, that takes care of the problem for you guys. Let me know if anything else comes up.

    Plugin Author Ben Marshall

    (@bmarshall511)

    Good news! I found the issue with GF not being auto enabled & a fix will go out in v4.5.0 within the next hour or 2. Thanks for letting me know about it & let me know if you have any more issues.

    Feel free to submit and bug/feature requests here: https://github.com/bmarshall511/wordpress-zero-spam/issues

    Thread Starter David Waumsley

    (@waumsley)

    Thanks Ben, I appreciate the work you have done.

    Sorry for the late response and the lack of clarity. At the time of writing the spam that was getting though seemed to be all bots.

    I looked at the sites of client’s reporting the problem. These had gone from zero Gravity Forms spam (of any kind) to 4 – 6 a day. All the usual stuff “Are you lonely”, Want a free website” and “Looking for “a risk free business” etc.

    I have continued to update and it looks like all is good across a range of sites.

    Plugin Author Ben Marshall

    (@bmarshall511)

    That’s great to hear! Let me know if anything comes up.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Not stopping Gravity Form spam anymore’ is closed to new replies.