Support » Plugin: OG » Not showing the Thumbnail

  • Hello, can anyone help me why can’t the thumbnail of the page is not showing when I share a link to the website that I’m developing? I’ve used this plugin before and it worked properly. I hope someone could help me.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Marcin Pietrzak

    (@iworks)

    hi @tristansalonga

    I checked:

    https://eton.com.ph/about-us/

    And FB og debugar says:

    Invalid Image Content Type
    Provided og:image URL, https://eton.com.ph/wp-content/uploads/2020/09/AboutUs-New.jpg could not be processed as an image because it has an invalid content type.

    Check it please:

    https://developers.facebook.com/tools/debug/?q=https%3A%2F%2Feton.com.ph%2Fabout-us%2F

    It looks some wired server settings.

    Look at the direct request:

    =$ HEAD https://eton.com.ph/wp-content/uploads/2020/09/AboutUs-New.jpg

    404 Not Found

    Cache-Control: no-cache, must-revalidate, max-age=0
    Connection: close
    Date: Mon, 12 Oct 2020 06:20:45 GMT
    Server: Apache
    Content-Type: text/html; charset=UTF-8
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Client-Date: Mon, 12 Oct 2020 06:20:45 GMT
    Client-Peer: 174.139.160.129:443
    Client-Response-Num: 1
    Client-SSL-Cert-Issuer: /C=US/O=DigiCert Inc/OU=www.digicert.com/CN=RapidSSL RSA CA 2018
    Client-SSL-Cert-Subject: /CN=eton.com.ph
    Client-SSL-Cipher: TLS_AES_256_GCM_SHA384
    Client-SSL-Socket-Class: IO::Socket::SSL
    Content-Security-Policy: frame-ancestors 'self'
    Link: <https://eton.com.ph/wp-json/>; rel="https://api.w.org/"
    Set-Cookie: cookielawinfo-checkbox-necessary=yes; expires=Mon, 12-Oct-2020 07:20:45 GMT; Max-Age=3600; path=/
    Set-Cookie: cookielawinfo-checkbox-non-necessary=yes; expires=Mon, 12-Oct-2020 07:20:45 GMT; Max-Age=3600; path=/
    X-Content-Type-Options: nosniff
    X-Frame-Options: SAMEORIGIN
    X-XSS-Protection: 1; mode=block
    

    It looks like some server settings.

    Marcin

    Hello Sir, Thank you so much for this. Can you help me on how to fix this error? Thank you!

    Plugin Author Marcin Pietrzak

    (@iworks)

    @tristansalonga

    I can’t.

    How can I help if your own server return 404 in some circumstances?

    Please ask your hosting provider why it’s happened.

    Marcin

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.