Support » Plugin: Add-on WooCommerce - MailPoet 3 » Not showing the option to subscribe

  • Resolved knireis

    (@knireis)


    Hi,
    I installed this plugin and set it up.
    But nothing shows up on the checkout form. Neither position seems to work.

    Regards

Viewing 13 replies - 1 through 13 (of 13 total)
  • Hi @knireis,

    Can you please share these information about your WordPress installation —

    1. WordPress version.
    2. Woocommerce version.
    3. Add-on WooCommerce version.
    4. Active theme name and version.
    Any other Woocommerce addon those are active.

    If you can provide us with correct information, we can re-create the problem what you’re facing can be solved as quickly as possible.

    Thanks

    Thanks for the quick response:
    1 5.02
    2 3.5.3
    3 1.1.0
    4 astra 1.6.2
    5 WooCommerce Extra Fee Option and WooCommerce Weight Based Shipping but disabling them does not solve the issue.

    regards

    Hi @knireis,

    Thanks for the information. We will check the issue.

    Thanks

    here is a link to the development site: https://nieuw.netjesminiaturen.nl

    Hi @knireis,

    Thank you for the information. We have tested the plugin with your versions and it seems to work on our setup. Can you please check these two scenario and let us know if you still getting this issue :

    1. Are you trying to use the checkout page while logged in as WordPress Admin user, if yes, you won’t see the subscription section, as all Admins are already subscribed to a default Mailpoet List.

    2. If the user you are logged in is subscribed lists on your website, you won’t see the subscription section on checkout page.

    And please make sure to set proper settings on WooCommerce >> Settings >> Mailpoet >> MailPoet WooCommerce Add-on. Specially the “Subscription Position” field, this is where your subscription field will show up on checkout page.

    Hope this helps and if you still get the same issue, please let us know. We will be happy to assist you with this.

    Thank you,
    Tikweb Team

    Hi,

    I noticed that it is displayed for a second, but then it is removed again. I made a screencast.
    [video src="https://nieuw.netjesminiaturen.nl/wp-content/uploads/2019/01/screencast-nieuw.netjesminiaturen.nl-2019.01.09-09-48-12.webm" /]

    Regards

    I switched to 2019 theme and the same thing happens, during the loading of the ‘payment section’ the option is shown but half a second later it disappears again.

    Hi @knireis,

    We have fixed this issue on our new release v1.1.2 , please update.

    Thank you,
    Tikweb Team

    Thanks!

    I found the same issue and I understood that it’s hiding even if the user is subscribed in “wordpress user”.
    Because every users are automatically subscribed to that list, I never see mailpoet in the cart.
    I tried to change the user status in Mailpoet from “subscribed” to “canceled” and in this case the option is showing.

    I have everything updated to the last versions

    Hi @mauroit,

    This is a feature of Mailpoet and it subscribes every WordPress users ( Subscribers or even WooCommerce Customer role) to a default List named “WordPress Users”.

    Our plugin checks if a user is subscribed to Mailpoet or not and depending on this condition shows the subscription form. So if a user is already a subscriber or a returning customer of WooCommerce, we don’t show the subscription form to them.

    Hope these information helps.

    Thank you,
    Tikweb Team

    Is there an option in PRO version to show only the exact and only one MailPoet list associated with a certain product which is in the cart on the checkout page so that the customers can check to subscribe to that list without bothering the customer to find his or her corresponding list among 20 lists to check it?

    Plugin Author ehsantikweb

    (@ehsantikweb)

    Hi All,

    Assuming the issue got resolved.

    Thanks,
    Tikweb Team

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Not showing the option to subscribe’ is closed to new replies.