Support » Fixing WordPress » Not showing real user IP address after uploading new wp-content folder

  • Hi WordPress,

    Few days ago suddenly my site was not showing any content, I have check in cpanel, the wp-content folder was not in its directory, so I have moved a wp-content folder from my another unactive addon domain’s directory into this directory.
    Now my site is showing all content but I have noticed one issue that my site is showing site’s server IP address instead for all new users IP addresses. I have tried some plugins which are showing IP addresses but with all plugins it is showing site’s IP, however in comments it is showing real user IP address.

    I will really appreciate If any one guide me that how to configure or fix this issue.

    Regards,

    Chetan

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hello Chetan,

    I don’t really understand what you are trying to do with your users’ IP adresses, could you provide more explanation about your goal here?

    Also, it could help if you list the plugins you tried.

    Regards,

    Hi Sylvain,
    Thanks for reply, I have tried to detect IP addresses of registered users through plugins Formidable Registration and Register IPs.

    The IP of registered users helps me to ensure that the user, its postal address and country submited while registering at my site are correct or not. The formidable registeration has also option to block any registered user by IP if he added some wrong content in my site. And most importantly I think it is an configuration error to be corrected because two months ago my site was showing real IP addresses of all users and now it showing only one IP i.e server IP address.

    I have also contacted to firmidable support they are saying:
    “By copying the entire wp-content folder from another installation you may have affected a file that Formidable relies on. The next step unfortunately is either a fresh install of WordPress, or restoring your site from a backup previous to when this issue began.”
    And unfortunately I have no saved recent backup.

    Chetan

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Not showing real user IP address after uploading new wp-content folder’ is closed to new replies.