WordPress.org

Forums

Author Product Review
[resolved] Not showing in Google (13 posts)

  1. camafive
    Member
    Posted 2 years ago #

    Hi, i was using this plugin and it was working perfectly but now google just don't show the stars, i've tested a link in the google's testing tool and it says

    Warning: Incomplete microdata with schema.org

    this is an example link i tested in the rich snippets testing tool

    http://goo.gl/mwsV8

    http://wordpress.org/extend/plugins/author-product-review/

  2. Rajesh Namase
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Camafive, I already updated the plugin - Latest version is 1.1, try latest version and let me know if any problem is there, thanks for using my plugin.

    Here's the Rich Snippet Preview Link.

  3. camafive
    Member
    Posted 2 years ago #

    Hi, sorry for the delay, but i didn't get any notification mail, but it does not work for me, i reinstalled the plugin and update one post and test it there and no stars, the same problem. i will try to publish another new post to see how it goes.

  4. camafive
    Member
    Posted 2 years ago #

    mmm... i try it in two wordpress sites, and it does not work for me

  5. Rajesh Namase
    Member
    Plugin Author

    Posted 2 years ago #

    Are you sure you're using latest plugin - version 1.1? I know problem was there in 0.9.1 version. It's working fine on test site as well as on TechLila. Here's the Rich Snippet Preview Link.

    I just checked link provided by you, it seems to be you're not using (either installed or activated) Author Product Review plugin, no markups are added in your post. Let me know links where you've added review in your post.

  6. camafive
    Member
    Posted 2 years ago #

    that was because i uninstalled, i'm using the latest version, look this is an example post with rating 5 but it show me the warning--->

    Link for testing

  7. Rajesh Namase
    Member
    Plugin Author

    Posted 2 years ago #

    I've confirmed that you're not using latest version, see source data:

    In your source code following line is not included

    <div itemprop="itemReviewed" itemscope itemtype="http://schema.org/Thing">

    In latest version 1.1 I've changed schema.org markup code and added this to validate it. Please check once again, I've checked it on 3 different sites and plugin working without any problem,

    Check this URLs in Rich Snippet tool:

    http://www.techlila.com/axvoice-voip-provider/

    OR

    http://xtendedview.com/computer/windows/softwares/easiest-way-to-secure-your-computer/1317/

    Last one is testing site so I'm not adding URLs here.

    I've added review markups on 12-15 posts, above are two samples for your reference.

    Let me know if you've any further issues. Thanks for using my plugin.

  8. camafive
    Member
    Posted 2 years ago #

    but that's weird, because i have 1.1, what i think is that before i had the other plugin that is similar to this one, the one that is called review schema, when it stopped working i change to yours, so i think that because is the same plugin with some modifications maybe is getting the same info from the other. i'm going to remove yours and place a garbage collector plugin to see if i can remove info from the other.

  9. camafive
    Member
    Posted 2 years ago #

    I've removed it and installed it again and nothing changes, i check the plugin and in fact it has that line of code, but it does not insert it in the front end page. if you want i can give you admin priority in my website so you can check that i have last version

  10. camafive
    Member
    Posted 2 years ago #

    now it's working but i have to place something in Name of Product Reviewed for it to work...is there a way to leave that empty? or i have to put something there always?

    Testing Clic

    Edit: I've modified the plugin to have that filled automatically with some info, or if you have another solution for not filling it, it would be better.

  11. Rajesh Namase
    Member
    Plugin Author

    Posted 2 years ago #

    Yeah, you're adding schema markup for product review, so logically product name is must. I don't think so there is any problem adding name of the product.

    You can modify plugin so it'll take post title as product name. I'll not provide such options because I don't think so it's too useful. Thanks.

  12. camafive
    Member
    Posted 2 years ago #

    ok, thanks for your kind help, i've already modified it, but anyway google is not getting my stars, in the testing tool now everything is ok, but in the serps nothing :(

  13. Rajesh Namase
    Member
    Plugin Author

    Posted 2 years ago #

    It'll take some time to appear in SERP. We've added valid schema.org markups, so don't worry.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Author Product Review
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic