Support » Plugin: Yoast SEO » Not Showing Facebook Preview and thumbnail

  • Resolved mikesurmadesign

    (@mikesurmadesign)


    When I try and share a page from my website it will not show the thumbnail image and only shows the meta from the home page. When I try and debug it gives me this message. The following required properties are missing: og:url, og:type, og:title, og:image, og:description, fb:app_id. I have the facebook preview enabled on the yoast plugin, not sure what is going on, any help would be great. Thanks

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • As I checked your site source, it already had those open graph tags but before those tags is a HUGE stylesheet tag. I measured its size and it is 1.2 MB on page size. I don’t know why you need that HUG CSS load directly on the page source before title tag. that will slow down your site a lot and may lead to many other problem include Facebook debug.

    I do not know why it is so big either, I do not have much custom css on my site and my theme is a top notch theme. Any idea on how I could fix this issue? It was showing the preview just fine until a couple of days ago..Thanks for your help.

    Plugin Support Michael Tina

    (@mikes41720)

    We checked your article https://mikesurmadesign.com/does-my-website-need-an-ssl-certificate/ and scraped it a couple of times on the Facebook Sharing Debugger Tool and it now seems to be showing the correct open graph tags and preview as expected. Please help check and verify.

    Yes..I was able to get the large css file off of the home page and it started working..Thanks for your help.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Not Showing Facebook Preview and thumbnail’ is closed to new replies.