Support » Plugin: Custom Sidebars - Dynamic Widget Area Manager » Not showing custom widgets?

  • Resolved jamiek47

    (@jamiek47)



    Hi,

    My post isn’t showing my custom widgets.

    It is showing different widgets than default, but it is showing the ARCHIVES and META widgets instead of the ones I made?

    What could be wrong?

    I have latest WordPress updated.

    Thanks,
    Jamie

Viewing 12 replies - 1 through 12 (of 12 total)
  • Ok, it is a conflict with the plugin Q2W3 Fixed Widget https://wordpress.org/plugins/q2w3-fixed-widget/

    As when I disable Q2W3 Fixed Widget, it works.

    How can I make your plugin work with Q2W3 Fixed Widget?

    Thanks

    Plugin Contributor Predrag Dubajic WPMU DEV Support

    (@wpmudev-support1)

    Hi @jamiek47,

    Apologies for the delay here.

    I did some tests on my installation by creating new Sidebar, adding custom widget in it and then assigning it to one of my posts and also all of posts type and I can still see it properly.
    Of course Q2W3 Fixed Widget was active the whole time and I even tried with Fixed widget enabled and disabled but it didn’t made any difference.

    Can you check if this works for you when using default WP theme or if I’m missing some steps here?

    Cheers,
    Predrag

    Hi,

    Strange, it does work with the theme Twenty Sixteen.

    What do you think the issue could be?

    Thanks

    I’m actually still seeing this (hosted WP) – Any luck WPMU? Any suggestions … can’t really turn Jetpack off ;/
    https://dl.dropboxusercontent.com/u/118962/WordPress/doesnt-save-setting.gif

    Just to add to the mix, some pages still show the custom one, but dont indicate it in the admin interface, and for some reason also stop working at times too.

    <Moving To Other Thread>

    @reapazor I’m not sure why you are replying on this thread?

    Wrong thread 🙁 sigh. Had two open.

    Plugin Contributor Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello @jamiek47,

    Strange, it does work with the theme Twenty Sixteen.

    What do you think the issue could be?

    It seems that there is conflict with plugin caused by the theme. What theme are you using?

    kind regards,
    Kasia

    Plugin Contributor Predrag Dubajic WPMU DEV Support

    (@wpmudev-support1)

    Hi @jamiek47,

    Thanks for the info, the issue is definitely theme related.

    I have installed it on my site and could see the issue happening.
    I noticed that theme is outdated as it hasn’t been updated for over two years and the code used for sidebar doesn’t follow WP development rules so Custom Sidebars can’t do it’s job.

    What happens with this theme is that it if you don’t add any widgets in sidebar it will instead load predefined widgets, Archives and Meta.
    So when you enable that sidebar to be replaced it reads it as empty and instead of letting Custom Sidebars to load its widgets it shows the default one.

    I was able to get it working in the end by editing theme functions.php file and defining widget ID like this:

    register_sidebar(array(
    	'name' => 'Right Sidebar',
    	'id'            => 'right-sidebar',
    	'before_widget' => '<div class="widget">',
    	'after_widget' => '</div>',
    	'before_title' => '<h3>',
    	'after_title' => '</h3>',
    ));

    Where ‘id’ => ‘right-sidebar’ is the part that I added.

    After that I had to add one widget to “Right Sidebar”, enable for it to be replace and select it in single post again as well.

    Also, widget styling was wrong so I had to edit my custom sidebar and add proper widget and title holders like this:
    https://screencast.com/t/rZ6iVxxbKHR2

    So after all that it started working fine but I would strongly suggest switching to newer theme that’s still supported by its developers.

    Cheers,
    Predrag

    Thank you, thank you, thank you! Works a treat 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Not showing custom widgets?’ is closed to new replies.