Support » Plugin: WooCommerce Pay Per Post » Not showing button

  • Resolved kafar

    (@kafar)


    Hello,

    I installed WooCommerce plugin and your plugin. I set any parameter in two plugins. But when I click on the post set with your plugin I read the message I set in Pay per Post plugin but I don’t see any button to checkout.
    What is wrong?
    Thanks

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Matt Pramschufer

    (@mattpramschufer)

    Can you send me a URL that I can look at? Also, did you make sure to include the woocommerce shortcode in the Settings for Restricted content message? Like https://ps.w.org/woocommerce-pay-per-post/assets/screenshot-1.gif?rev=1886975

    kafar

    (@kafar)

    Unfortunately I can’t give you the url because I’m working in a staging environment.
    I’m using now the base verison o fyour plugin, not the premium.

    However, in Settings for restricted content message I included post and page.

    Plugin Author Matt Pramschufer

    (@mattpramschufer)

    Kafar,
    Do in the settings page for the restricted content, do you have the following?

    <h1>Oops, Restricted Content</h1>
    We are sorry but this post is restricted to folks that have purchased this page.
    
    [products ids='{{product_id}}']
    kafar

    (@kafar)

    I customized that message:

    Caro lettore, ‘{{product_id}}’ è un articolo di categoria Premium e per la lettura ti chiedo un piccolo contributo. Tale contributo mi consentirà di mantenere il blog e offrirti sempre articoli di qualità. Grazie.

    This message show when I click on the article, but with no button for checkout or similar.

    Plugin Author Matt Pramschufer

    (@mattpramschufer)

    You need to replace ‘{{product_id}}’ with [products ids='{{product_id}}'] that is the standard WooCommerce shortcode for showing product add to cart buttons. You can look more on the woocommerce shortcode at https://docs.woocommerce.com/document/woocommerce-shortcodes/#section-6

    kafar

    (@kafar)

    Great! I was completely wrong….. I’m sorry.
    Then, if I upgrade the plugin to Premium I will can show partial part of article before to show the add to cart button? Or not?
    Thanks

    Plugin Author Matt Pramschufer

    (@mattpramschufer)

    Glad it is working now for you!

    For your question… yes and no. By default it will not show ANY content it will just show the Content Restricted Content that you have in your settings. However with the premium version you can override that Content Restricted block on each page. So you could technically just put an excerpt of the article in that area along with the shortcode to purchase the product and you could achieve what you are looking for.

    Let me know if that helps! Also, there is a free 7-day trial of the premium version if you just wanted to check it out and see if it works. If you have opted in when installing the plugin you should see a start your free trial button.

    kafar

    (@kafar)

    Ok.
    Can you write the workflow of the user from when click on the post?
    Actually I disabled WP account creation on my blog, then what I can do?
    Thanks

    Plugin Author Matt Pramschufer

    (@mattpramschufer)

    No, users need to have an account created as that is what tracks if they have purchased the product or not. Without that there is no way to know if the user had purchased the specific product.

    kafar

    (@kafar)

    but from WooCommerce I saw options settings to enable checkout less the account creation. Perhaps it’s not run with your plugin?

    Plugin Author Matt Pramschufer

    (@mattpramschufer)

    That is correct, this plugin requires account creation.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Not showing button’ is closed to new replies.