Support » Plugin: Event CLNDR » Not showing anything

  • I’m using WordPress 4.7.4 and Event CLNDR 1.03, but the plugin won’t show anything.
    The developer console gives me the following error:

    Uncaught ReferenceError: require is not defined
    at clndr.min.js:2
    at clndr.min.js:2

    How can I solve this?
    Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author i4nd90

    (@i4nd90)

    Hi there

    I am successfully running the plugin without any errors on a fresh install of 4.7.4.

    Could you please dump the list of your activated plugins so I can see if there are any potential conflicts? Also – what environment are you on? WordPress.com or self-hosted?

    Ian

    Thread Starter fdjvn

    (@fdjvn)

    Hi,

    Thank you for your reaction.

    I’m running a self-hosted environment. With PHP version 5.6.30 and MySQL version 5.6.35. I’m using the Brooklyn WordPress theme by United Themes

    The other plugins that i have are:
    – Contact Form 7, Version 4.7, by Takayuki Miyoshi
    – Easy Theme and Plugin Upgrades, Version 2.0.0, by Chris Jean
    – Portfolio Management by United Themes, Version 3.9
    – Pricing Tables by United Themes, Version 3.0
    – Shortcodes by United Themes, Version 4.2.4
    – Slider Revolution, Version 5.3.1.5, by ThemePunch
    – Twitter by United Themes, Version 3.1.1
    – WPBakery Visual Composer, Version 4.12.1, by Michael M – WPBakery.com
    – Yoast SEO, Version 4.7.1, by Team Yoast

    I tried deactivating all the plugins except Event CLNDR, but I still got the same error message. Could I be missing some kind of script?

    Thank you!

    Plugin Author i4nd90

    (@i4nd90)

    Thanks for the information.

    There’s something going on in your environment that’s causing the issue, I think.

    What’s happening is that the CLNDR.js script is looking to utilise any already loaded dependencies, and in your case thinks it’s found a Node/CommonJS/Browserify loading method to hook into. However when it uses require to bring in jQuery and Moment.js, this fails. Without looking into the specifics of your environment it’s hard for me to know why.

    Also this seems more like an issue with CLNDR.js itself over the plugin. It might be worth seeing if the issue is replicated in an implementation outside of WordPress – my hunch is that it will. In this case you’ll be better off opening an issue on the project’s Git unless you’re able to identify why this is happening specifically on your server.

    Sorry I can’t be of more help!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Not showing anything’ is closed to new replies.