Support » Plugin: WooCommerce PDF Invoices & Packing Slips » Not Show total sale

  • Resolved marioan

    (@marioan)


    Hello, greetings to all,

    I have installed the plugin and everything looked correct except that the invoice total does not appear, shipping costs appear, taxes but not the total.
    I have included a script to show what $this->get_woocommerce_totals() generates and contains the following:

    Array
    (
    [shipping] => Array
    (
    [label] => Envío
    [value] => 6,90€ (sin impuestos) vía Precio fijo
    )
    [tax] => Array
    (
    [label] => Impuestos
    [value] => 3,53€
    )
    [payment_method] => Array
    (
    [label] => Método de pago
    [value] => Transferencia bancaria directa
    )
    [order_total] => Array
    (
    [label] => Total
    [value] =>
    )
    )`

    Thank you very much for your attention, best regards.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Darren Peyou

    (@dpeyou)

    Hi @marioan,

    The value of your total is empty. 🙁
    – Is it like this for all your orders?
    – Do you have a code snippet targeting your totals section? If yes, could you post that here?
    – Do you see the total in the email sent by WooCommerce? What’s shown in the email should basically be the same as what’s shown in the PDF invoice.

    My 1st thoughts are that there’s possibly a 3rd party plugin (or a custom filter) overriding the total somewhere.

    • This reply was modified 4 months ago by Darren Peyou. Reason: additional question
    Thread Starter marioan

    (@marioan)

    Hi Darren,

    Indeed !! the total does not appear in the order email, I am going to remove all the plugins to find out which one is causing this behavior. It must be a plugin because I don’t have any script created for this website.

    Thank you very much for your attention, best regards 🙂

    Plugin Support Darren Peyou

    (@dpeyou)

    Hi @marioan,

    Were you able to learn anything new through testing?

    Thread Starter marioan

    (@marioan)

    Hi @dpeyou,
    Please excuse me that I did not expand my information. The plugin that gave problems was “Product Prices by User Roles for WooCommerce”. I don’t know if because of my template or for another reason there was no way it would work well. I ended up uninstalling it.
    Thank you very much for your attention 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.