Support » Plugin: Email Subscribers & Newsletters » Not sending to entire list?

  • Resolved grilling24x7

    (@grilling24x7)


    When I write a new post I noticed that I wasn’t getting auto emails anymore. When I go into tools – email log, i see that only about a fraction of my email list is being notified. It seems to be alphabetical. Only emails starting with A-C have been sent. After that the log shows an older post and not the new one.

    The reason I found this is b/c my email starts with G and only emails are sent to addresses starting with A-C?

    What could be going on here?!

    https://wordpress.org/plugins/email-subscribers/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author storeapps

    (@storeapps)

    Hi,

    Are you using latest version of the plugin?

    Also, can you please make sure all the recipients address have been selected when you are sending out notification email?

    Thanks for responding!

    This plugin used to send an auto email when I simply posted something new? I dont recall ever selecting recipients for an email. I have about 500 people. When I look in “subscribers” none are checked but 99% are confirmed.

    I’m confused on what to do next and where to check.

    Yes, just got most recent plugin.

    John

    Plugin Author storeapps

    (@storeapps)

    Hi,

    Can you please check that the new post that you are publishing, that category is checked under the Notification tab? Because if that category is not checked, then post published to that category won’t be send to subscribers.

    Also, Are you sending emails via cron? If yes, then can you please check if ‘Mail Count’ option (under WordPress->Email Subscribers->Cron Mail) is set to more than 500 or not?
    On the otherhand, if you are not sending mails via cron, then could you please have a check with your Host Provider and ask them to increase Maximum Hourly Email Limit value and then have a check with the same functionality and do let us know your views on the same.

    Actually I just checked my email log in wordpress and it looks like about 90 emails were just sent. It’s alphabetical. Starts with the A’s and stops around D.

    4 pages of log showed the new post (about 20 emails each) and then the 5th page showed 10 emails. So that isn’t near the host max of 200 per hour.

    Plugin Author storeapps

    (@storeapps)

    Hi,

    Then you should check under Email Subscribers->Send Mail tab that you are selecting ‘ALL’ option while sending notification. That would ensure all email addresses are selected while sending notifications.

    I see what you were thinking, but all of the emails were already checked.

    Plugin Author storeapps

    (@storeapps)

    Hi,

    Can you please try replicating the same issue with only Email Subscribers plugin active (and rest all plugins de-activated) maybe on a testing/staging site and let us know if it is working correctly or not.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Not sending to entire list?’ is closed to new replies.