Support » Plugin: MailPoet Newsletters (Previous) » Not sending every hour

  • Hi

    I have a weekly newsletter with a limit of 80 emails per hour (due to hosting limitations), and a cron job that every hour calls the URL to send mails if necessary. However mail batches are sent only every 2 hours.

    My opinion is that the problem comes from the time it takes to send every batch. My newsletters are long and habe large images so they take time to be composed.

    For example, if sending starts at 9:00:00 it will finish ten seconds later i.e. 9:00:10 (I monitored with Cpanel when mails are sent out); so at 10:00:00 yet not one hour has elapsed and eventhough the cron triggers the task Mailpoet won’t send anything.

    Should’nt the one hour interval count from the beginning of the batch, instead of the end, be taken into account?

    Best regards

    Zulok

    • This topic was modified 7 years, 4 months ago by zulok.
    • This topic was modified 7 years, 4 months ago by zulok.
    • This topic was modified 7 years, 4 months ago by zulok.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi Zulok,

    The best results we’re seeing is by sending more often, less emails.

    So if you have a hourly limit of 80 newsletters, you can send 20 newsletters each 15 minutes.

    Thread Starter zulok

    (@zulok)

    Hi MailPoet,

    Thanks for your answer.

    However I am not sending 80 newsletters per hour, but one newsletter with a limit of 80 emails per hour. The limit of my hosting is 100 emails per hour. Perhaps it is a different scenario.

    If what you suggest is to send the newsletter 4 times per hour and 20 emails each time, then I do not know how to customize it with MailPoet admin options to do so.

    Thanks

    Zulok

    Hi Zulok,

    You can customize the sending frequency at MailPoet > Settings > Send With…

    Let us know if that works.

    Thread Starter zulok

    (@zulok)

    Hi

    If I select 20 emails every 15 minutes, and set a cron task to trigger the newsletter, mails are sent every half an hour actually. It seems the same problem as reported initially with different time frames

    Thanks

    Zulok

    If you created a cron job, can you change it to run each 5 minutes with 10 emails?

    Does this help?

    Thread Starter zulok

    (@zulok)

    Hi Mailpoet

    No, it has not changed. Now it is sendind 10 emails every 10 minutes.

    Zulok

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Not sending every hour’ is closed to new replies.