• I have plugin set up with Twilio, and I bought a phone number at Twilio. In plugin setting in WP admin, I can send a test text from the ‘test’ tab. But when I send a text to usergroup in ‘Bulk SMS’ tab, text does not get sent. On text that do not get sent, I see these error logs in Twilio:

    ——————————

    Error – 52182
    Messaging Service not specified
    In order to send SMS messages with Notify you need to configure a Messaging Service and connect it with your Notify Service. Messaging Services make it easy to build SMS application by automatically selecting an optimal From phone number from pool you can define.

    ——————————

    PS: I tried to contact you through support form in WP admin, but never got a response.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author spartac

    (@spartac)

    Hi Andrew

    The error you are receiving is returning from Twilio console, our plugin just display it as it is .
    try to look into the logs and see what you get.
    I assume you either using a free Twilio Number, or you didn’t configure your Twilio settings properly, You should specify the ” messaging service”

    and in order to debug that, try to send a test message without any addon activated and check out the logs.
    Please check that out and let me know how I can help You better.

    Thread Starter andrew55

    (@andrew55)

    What logs do you suggest I look in? WP logs? Twilio logs?

    Where do I specify the ”messaging service”??

    I’m also wondering why the plugin works when I send a text from the ‘Test’ tab, but not from the ‘Bulk SMS’ tab? To me, this seems to indicate texting is working fine, but just not from the Bulk SMS feature of your plugin.

    Thanks for any help with this.

      Plugin Author spartac

      (@spartac)

      No Twilio Logs, but my plugin’s logs, You find them in the tab .

      The bulk service requires ” Messaging Service ” ID , You can get it from your Twilio Console here https://www.twilio.com/console/sms/services
      Then copy it and paste it into the Settings of WP SMS Plugin.
      After you do this, make a test by sending a test message ” you find it in the ” test ” tab.
      And read the logs tab if anything changes

      Thread Starter andrew55

      (@andrew55)

      I followed your suggesting when setting up Messaging Service ID. I copied and pasted the Messaging Service SID into Settings of WP SMS Plugin.

      I now see this error when sending test bulk text:

      [HTTP 404] Unable to create record: The requested resource /Services/MGe7a76b9e8ffe84a4ad2385fff53de6b0/Notifications was not found

      I see a similar messages in your plugin’s error logs.

      Any ideas on what might be causing this? Are there any specific settings in Messaging Service (in Twilio) that I need to check? For example, I put my purchased Twilio phone number in the Sender Pool. Is this correct?

      Thread Starter andrew55

      (@andrew55)

      Can someone please get back to me? I purchased the Bulk SMS plugin from you guys, and it has never worked. I contacted you through your website, and no one every replied to me. I just want to be able to send simple bulk texts through WordPress using Twilio, nothing fancy.

      Plugin Author spartac

      (@spartac)

      Hi Andrew please send a temporary admin access to a live or staging site.and send the creds to support@wpsms.io

      i will help you from there

      Thread Starter andrew55

      (@andrew55)

      Thank you for prompt reply. I sent credentials.

      Plugin Author spartac

      (@spartac)

      Hi, have you sent them to support@wpsms.io ? I didn’t receive any email from You.

      forward it again please and cc to rahim 7707 @ gmail.com ( remove spaces)

      Plugin Author spartac

      (@spartac)

      Got it now

    Viewing 9 replies - 1 through 9 (of 9 total)
    • The topic ‘not sending, error inn Twilio’ is closed to new replies.