Support » Plugin: MC4WP: Mailchimp for WordPress » Not sending Confirm Subscription email to subscriber

  • Resolved Panos_M

    (@panos_m)


    Hello,

    after update WordPress to version 4.7 and MailChimp for WordPress to the latest version 4.0.11 the subscriber haven’t received the Please Confirm Subscription email.

    The subsription message looks as it should be: Thank you, your sign-up request was successful! Please check your email inbox to confirm.But not a confirm email.. I was able to test this in two different websites. Using gmail and yahoo emails for testing. Before the update everything works fine. The Double opt-in option is enabled. Also in the debug log not errors.

    Only this warning: [2016-12-16 14:05:35] WARNING: Form 2244 > pano*@in*********.net is already subscribed to the selected list(s)

    The above email and also the other emails ( gmail, yahoo ) haven’t received emails.

    Where is the problem?

    Best Regards,
    Panos

    • This topic was modified 2 years, 9 months ago by  Panos_M.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Harish Chouhan

    (@hchouhan)

    Hey Panos,

    Please note that we have no control over the “Double Opt-in” emails sent by MailChimp. If you want to test if our plugin is sending the data, you can disable double opt-in and test.

    Secondly the error suggests that the email you are trying to subscribe is already in your MailChimp list.

    Hello Harish,

    first of all i want to remind you that as i mentioned im my previus message, the subscribers received the Confirm Subscription email before the update. Everything works fine.

    Secondly in the Form Settings i disabled the Double opt-in option as you suggesting although your tip We strongly suggest keeping double opt-in enabled. Disabling double opt-in may result in abuse.. Nothing change. I haven’t received any email to confirm the subscription.

    Please note that i am not testing with the email in the debug log. I am using a gmail and a yahoo email for the test. And guess what? Although i get a successful message, when i am trying with the same email again i get the successful message.

    • This reply was modified 2 years, 9 months ago by  Panos_M.

    info update: for the first website i create a new mailchimp account and this fixed the problem.
    For the second website i had to update the opt-in confirmation form in the existing account and this for some reason also fixed the problem. If it will be another issue i let you know.

    Hi Panos!
    I’m experiencing the same issue with Yahoo an Gmail users in a newly created website. I’ve created a new mailchimp account, as you did, but it doesn’t work. I’d like to try your second solution, but I don’t know hoy to update the opt-in confirmation, could you please briefly tell me?

    Thanks a lot,
    Nieves

    Same here, Any updates on how to solve that, suscribers dont receive the double opt in emails and they get straight to the list.

    Plugin Contributor Harish Chouhan

    (@hchouhan)

    Hello @renzosalvador,

    In future please create a separate ticket so we can reply and assist you in resolving your issue.

    You mentioned your subscribers do not get opt-in email but are added straight to your list, this would mean you have disabled “Double Opt-in” in our form settings. Please enable it and test again.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Not sending Confirm Subscription email to subscriber’ is closed to new replies.