Support » Plugin: Entry Expiration for Gravity Forms » Not seeing the updates

  • Resolved TamsiPhoenix

    (@tamsiphoenix)


    I have read you changed the functionality so by default this is not on for each form, but when I install it, It has the checkbox checked for each form. I uninstalled and downloaded direct from your website, but still I see no change, all the forms have it enabled by default. Is there something I am doing wrong? Also is there a way to clear in hours rather than days?

    Thanks and good work on the plugin 🙂

    https://wordpress.org/plugins/gravity-forms-entry-expiration/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Travis Lopes

    (@travislopes)

    Could you test this update please before I push it live? It should no longer automatically enable the forms to be included in the entry expiration if you are doing a fresh install of the plugin.

    (If the forms are already enabled for entry expiration before running this update, they will still be enabled.)

    Yes this works great! Thanks for that 🙂 Any chance of entries being able to be cleared hourly instead/as well as daily?

    Thanks for the super fast response!

    Plugin Author Travis Lopes

    (@travislopes)

    Could you please test this build of the plugin?

    It includes the ability to set the expiration time in hours, days, weeks or months.

    Ahh yes I see this functionality. Great! I see at the top of the page it reads “Gravity Forms Entry Cleaner examines your entries every night at midnight and deletes any entries older than the time frame designated below.”

    Does this mean if you set the time to 2 hours, it will still only clear them once a day, as the job only runs at midnight?

    Plugin Author Travis Lopes

    (@travislopes)

    It actually runs every hour but I missed that text in the update.

    That message has been updated and plugin update released.

    Ok, so unfortunately the most recent version you sent me deleted all entries in every form that was active at the time, even those where it was not enabled. I should have installed it on staging really. Just so you know

    Plugin Author Travis Lopes

    (@travislopes)

    Do you know how old those entries were at the time? What did you have the expiration time set to?

    Anywhere between 4 hours and 4 months, I set the expiration to 2 hours. I must stress it deleted entries on forms with the remove entries function not enabled

    Plugin Author Travis Lopes

    (@travislopes)

    I just pushed out a patch that fixes this issue. I apologize that this issue didn’t get caught in QA.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Not seeing the updates’ is closed to new replies.