Support » Plugin: PayPal for WooCommerce » Not seeing spinner while checkout processes the order

  • Resolved Jon Fergus

    (@jon-fergus)


    We have both PayPal Credit Card (REST) and PayPal Express Checkout activated. When the customer clicks “Place Order”, the screen greys out but no spinner shows. Obviously this makes it seem like an error or a frozen page rather, which is not ideal. I see from a previous support thread here that a spinner is supposed to show. Need help figuring out why it isn’t for us. Details below (all our plugins and theme are up to date).

    Theme: Avada Version 5.4.2

    Active Plugins (all up to date):
    Woocommerce Version 3.3.5

    Adminimize
    AfterShip – WooCommerce Tracking
    Akismet Anti-Spam
    All In One SEO Pack
    All-in-One WP Migration
    Contact Form 7
    Fusion Builder
    Fusion Core
    Google XML Sitemaps
    Instagram Feed
    MailChimp for WordPress
    PayPal for WooCommerce
    Really Simple SSL
    String Locator
    TinyMCE Advanced
    WC Hide Shipping Methods
    Product Alerts for WooCommerce
    WooCommerce PDF Invoices & Packing Slips
    WooCommerce – Store Toolkit
    WP Mail Logging
    WP Mail SMTP

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Contributor Oliver

    (@angelleyesupport)

    @jon-fergus, Thanks for contacting here, well I have just tested on my demo site and its showing me spinner, so my rough guess is that it could be something either from theme / any of installed plugins.
    Can you either turn OFF all plugins, clear cache and then check?
    Another thing could be to switch to Basic Twenty theme and see if you get spinner working back?
    I will wait for your feedback.
    Thanks!

    I’ve played around a bit but haven’t been able to get the spinner working. Will continue to troubleshoot and let you know if I find the culprit.

    Plugin Contributor Oliver

    (@angelleyesupport)

    Sure, let me know if you need any further assistance.
    Thanks

    I haven’t been able to figure out why this isn’t working. Perhaps you could test it on our staging site? (everything is in sandbox mode)

    stage2.fitafvegan.com

    Maybe you’ll be able to see what the problem is.

    Plugin Contributor Oliver

    (@angelleyesupport)

    @jon-fergus well that’s hard to say what could be the reason for this to not work for you, but we are not seeing that on our sandbox site nor we have other reporting for this. So it would be difficult to say what is not letting that loader to work on your site specifically.
    If you like us to help you figure out that then I would like you to submit an order for premium support and we will work directly with you on your site and see whats going on there. I hope that is understandable.
    Thanks!

    Thanks Oliver. I’ll do some more troubleshooting and if I can’t get anywhere I’ll send in a premium support request.

    For anyone else with the same issue, I found a work-around solution via css that should work with any payment gateway plugins:

    .post-8 .blockUI.blockOverlay {
        background-image:url('/wp-admin/images/wpspin_light-2x.gif') !important;
        background-position: center !important;
        background-repeat: no-repeat !important;
        background-attachment: fixed !important;
    }

    The .post-8 part restricts the settings to the checkout page only (the number may differ on each site). Leave it out if you want the spinner to apply to any woocommerce divs. Also, to target the cart page functions, simply replace .post-8 with .cart-collaterals (at least for those using Avada theme).

    Plugin Contributor angelleye

    (@angelleye)

    @jon-fergus, thanks for sharing!

    I have this same problem and the CSS code did not make any difference. After placing an order my site will go gray with no spinner or any indication that it is responding for about 15 seconds before it goes to the order received page. Oftentimes my customers will click the button again and so their order goes through twice. Can anyone help me?

    Plugin Contributor Oliver

    (@angelleyesupport)

    @arlanh, Did you tried to run the basic debugging steps , like switching theme to basic twenty theme clear Cache and check again, also try to disable all extra plugins except for WOO and ours and then check again.

    Also, what theme you are using?

    Plugin Contributor Oliver

    (@angelleyesupport)

    Did you get it working?

    • This reply was modified 1 year, 8 months ago by Oliver.
    • This reply was modified 1 year, 8 months ago by Oliver.

    Thank you for the fix.

    I had the same issue with latest Avada theme and that fixed it. Important for those running into this issue to do what ‘Oliver’ suggested and change to the standard wordpress theme before disabling any plugin. If you can see the spinner after changing to the theme the fix posted by Jon Fergus will most likely solve your problem.

    All spinners were not working, not just woocommerce so i removed the ‘.post-8’ at the beginning as suggested.

    .blockUI.blockOverlay {
        background-image:url('/wp-admin/images/wpspin_light-2x.gif') !important;
        background-position: center !important;
        background-repeat: no-repeat !important;
        background-attachment: fixed !important;
    }
    • This reply was modified 1 year, 4 months ago by freezer33.
    • This reply was modified 1 year, 4 months ago by freezer33.
    Plugin Contributor Oliver

    (@angelleyesupport)

    @freezer33 Thanks for the input. Really glad to have such contributors in our user list. You are all awesome.
    Cheers!

    hbaum

    (@henrybaum)

    We’re using Avada too. The code works, but it works for every gateway, including one that has its own spinner, so two show up. Is there any way to limit it to Paypal Express?

    Plugin Contributor Oliver

    (@angelleyesupport)

    Hi @henrybaum,

    Sorry for delay in response.
    Are you aware of Google chrome site inspector or debugger? That’s you best tool here to debug it , find the right class and play with the CSS to get this adjusted to your needs.
    Thanks!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Not seeing spinner while checkout processes the order’ is closed to new replies.