Support » Plugin: Q and A FAQ and Knowledge Base for WordPress » Not seeing questions – plugin conflict with "Toggle the Title"

  • Resolved murokoma

    (@murokoma)


    Hi there,

    I’ve set up this plugin and had a strange problem that I could finally trace back to a plugin conflict with “toggle the title”, so I thoug I’d share it here.

    On the FAQ page, I did see the category titles, I did see the number of questions in each category, but I didn’t see any questions.

    So basicaly, it looked like this:

    ************
    General (2)

    Billing (5)

    Somethingelse (4)
    ************
    with no questions in between.

    When I used the search function, I could access the individual questions/answers, I also could access the individual FAQ pages directly. I just didn’t see the questions on the main FAQ page.

    Standard WP install, latest version of plugin and WP, I tried reverting to the standard theme (still the same problem) and then started deactivating plugins.

    Finall, I found what caused this – the plugin “Toggle the Title” http://wordpress.org/extend/plugins/toggle-the-title/.

    If this is activated, the q and a plugin will stop showing questions, as they are probably formatted as “titles”.

    INTERSTINGLY – even if the “toggle the title” plugin is set to NOT toggle the title on the FAQ page, it doesn’t work, so it seems to be a general incompatibility.

    Hope it might save someone from a few mins of bugfixing 😉

    Cheers,
    Robert

    http://wordpress.org/extend/plugins/q-and-a/

Viewing 6 replies - 1 through 6 (of 6 total)
  • avner.komarow

    (@avnerkomarow)

    Hi,
    This is fixed now (in 1.1).

    Note that it will still not work with Q&A because this plugin is intended for pages only – Q&A uses custom post types (like qa_faqs with the capability_type of post).

    But it will no longer conflict :-). (Look at the change log http://wordpress.org/extend/plugins/toggle-the-title/changelog/)

    murokoma

    (@murokoma)

    awesome! Thanks 🙂

    murokoma

    (@murokoma)

    marking as resolved.

    FYI: This issue also happens with Pippin’s “Easy Content Types” and the other “Show-Hide Content” plugin.

    I had to manual export ‘easy content types’ code and make my own custom plugin. Then it worked.

    For my Easy Content Types plugin, go to Content Types > Settings and check the box for Disable Taxonomy Archive Fix.

    Ah thanks Pippin! That totally fixed it. I didn’t even think to try that. I’ve used that setting on another Genesis site I built, but for a different issue.

    Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Not seeing questions – plugin conflict with "Toggle the Title"’ is closed to new replies.