Support » Plugin: Entry Expiration for Gravity Forms » Not seeing Expiration settings option

  • Resolved bsowebteam

    (@bsowebteam)


    activated the plugin and am seeing Expiry Seetings for individual forms (Step 5) but step 4 doesn’t seem to work (see below) – no entries are being deleted
    INSTALLATION
    1. Unpack the download package.
    1. Upload all files to the /wp-content/plugins/ directory, with folder
    3. Activate the plugin through the ‘Plugins’ menu in WordPress
    4. Navigate to the Entry Expiration Settings page inside of Gravity Forms and set the expiration timeframe.
    5. Navigate to the Form Settings page for each form you want to have entries automatically expire and include them in the expiration process.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Further query:
    4. Navigate to the Entry Expiration Settings page inside of Gravity Forms and set the expiration timeframe.
    where should I see this in the Dashboard – it isn’t showing under Forms

    Plugin Author Travis Lopes

    (@travislopes)

    I need to update the instructions on the readme.

    All configuration for Entry Expiration now happens at the form level. When on the Settings page for a form, there should be a new “Entry Expiration” tab where you can setup the automatic entry deletion for that form.

    yes, that is correct – I can see that and am filling in the options
    eg I say delete entries older than 10 mins
    and run deletion every 1 hour
    and update settings
    entries don’t get deleted !
    would I expect that after an hour all entries older than 10 minutes would disappear ?
    thanks

    I think I found the answer in another Topic
    it is controlled by the Members plugin – you have to add a permission to the user role to allow Expiry settings to be updated
    testing now but looks hopeful

    tested this and it is working now.

    if you use the Members plugin – under Roles, just enable
    – forgravity_entryexpiration Grant

    very useful plugin

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.