• Resolved susie.Q

    (@susieq-1)


    I installed your plugin last week and also gave it a 5 star review. It appeared to be working correctly but today I have noticed on my c-panel that I am still getting some visitors to the http version of my site.

    Your plugin is listed as defining the following:

    FORCE_SSL
    FORCE_SSL_ADMIN
    FORCE_SSL_LOGIN

    Are those added to the wp-config file or .htacess file?

    The only thing I am seeing in my wp.config file is the “FORCE_SSL_ADMIN” that I manually added to the wp.config file before I started to convert the site to https.

    Note, I moved the wp.config file up one level for security reasons so I do not know if that will affect the plugin from finding the config file.

    I did not notice any additions to the .htacess file.

    Thank you for any trouble shooting or help that you can provide.

    • This topic was modified 11 months, 3 weeks ago by  susie.Q.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author JS Morisset

    (@jsmoriss)

    Those constants are useful to selectively enable / disable HTTPS for the back-end, login webpages, etc., or to check their value in your filters / actions. See http://php.net/manual/en/language.constants.php for more info on PHP constants.

    It looks like you’re still using HTTP URLs in your widgets – you may want to update those. 😉

    js.

    I have checked each widget and all have been changed from http to https. I am unable to comment on the widgets that are generated by plugins.

    Does your plugin work dynamically or does it make hard changes to the wp.config file or .htaccess files?

    I read the info at the link you sent. I have no coding knowledge and didn’t understand it.

    Thank you.

    Plugin Author JS Morisset

    (@jsmoriss)

    Your web browser should have a “View Page Source” function – usually when you right-click on the page – it can be useful to search your webpage HTML for certain text, like “http://” for example:

    
    <div id="first" class="widget-area" role="complementary">
    <aside id="custom_html-4" class="widget_text widget widget_custom_html">
    <div class="textwidget custom-html-widget">
    <a href="http://mr-reeves.com/terms-of-use"><b>Terms of Use</b></a>
    </div>
    </aside
    ></div><!-- #first .widget-area -->
    
    <div id="second" class="widget-area" role="complementary">
    <aside id="custom_html-5" class="widget_text widget widget_custom_html">
    <div class="textwidget custom-html-widget">
    <a href="http://mr-reeves.com/privacy-policy-3/"><b>Privacy Policy</b></a>
    </div>
    </aside>
    </div><!-- #second .widget-area -->
    

    js.

    Thank you. Clearly, I forgot the footers. It has been several hours since I fixed those pages and I am still seeing visitors to the http version of the site in my c-panel.

    I give up and will try other plugins.

    • This reply was modified 11 months, 3 weeks ago by  susie.Q.
    Plugin Author JS Morisset

    (@jsmoriss)

    I’ve updated the plugin to include widget text.

    You should make sure the WordPress Settings > General > WordPress Address (URL) and Site Address (URL) values are HTTPS.

    If you webpages have only HTTPS URLs, then eventually search engines will update their indexes and you should see only HTTPS traffic. That usually takes a few days / weeks, not a few hours. 😉

    js.

    I changed the wp address and the site address last week right after I secured the backend via my config. file. Checked the urls on pages, posts,images and made url changes in side widgets and then installed your plugin for good measure. At that point I had a lock with the yellow in it indicating mixed content and traced it back to the photos in the top banner. Deleted those and re-uploaded them and got the green lock.

    I totally forgot to change the urls in the footer widgets but still had the green lock with that oversight which has now been fixed.

    Thanks for your patience. I’ll update the plugin and sit tight for a couple of weeks.

    Thank you again. Have a nice evening.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Not Seeing 100% Redirects’ is closed to new replies.