Support » Fixing WordPress » not secure connection

  • i am seeing not secure connections in some of my pages in my website ..can anyone help me to solve the problem?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Hello ankikas
    The reason you are seeing the “Not Secure” warning is because the web page or website you are visiting is not providing a secure connection. When your Chrome browser connects to a website it can either use the HTTP (insecure) or HTTPS (secure). Any page providing an HTTP connection will cause the “Not Secure” warning.

    It’s because some of your resources(e.g. images) are loading over http but your site is https. You have two options to fix them:

    1. First, find those resources and manually change them to https.

    2. Second, you can try this plugin https://wordpress.org/plugins/ssl-insecure-content-fixer/ if you are not able to fix them manually.

    I hope this will help you

    Thank you prashant ..i got it …i can now see a proper site …..BUT i have another different wordpress site wherein i did the same ..now it is giving me no access to login … what to do ??

    Activated the plugin there? Is that site on https?

    ankikas

    (@ankikas)

    i manually tried to change it to https as it was there in http….but as i saved the changes from that very moment i could not able to login to my site …

    Prashant Singh

    (@prashantvatsh)

    i manually tried to change it to https as it was there in http

    Where did you change and what did you change? Please check https://wordpress.org/support/topic/admin-still-wouldnt-work-over-ssl/

    ankikas

    (@ankikas)

    I could not able to get that ….i am having problem with this site – https://inspiringinfo.co.in/

    i tried to change http to https manually (by going to settings and general …then changed it from http to https )…..but when i saved from that moment i could not login again as it is showing to have a secure connection.

    In this site – heatherielove.in …doing it manually from http to https worked.

    But not in inspiringinfo.co.in

    • This reply was modified 4 months ago by ankikas.
    • This reply was modified 4 months ago by ankikas.
    • This reply was modified 4 months ago by ankikas.
    • This reply was modified 4 months ago by ankikas.

    can anybody help me on this

    i tried to change http to https manually (by going to settings and general …then changed it from http to https )…..but when i saved from that moment i could not login again as it is showing to have a secure connection.

    First thing let’s try to fix the login issue and for that, we need to revert back the URL from HTTPS to HTTP. Please check this guide https://wordpress.org/support/article/changing-the-site-url/

    If you have database access, please check https://wordpress.org/support/article/changing-the-site-url/#changing-the-url-directly-in-the-database

    Note: Please make a full site backup(including database) before making any change.

    Now i could see my page being logged in but could not access to any option…can only see the front page….. when i click on some option it shows error…..
    i have copy paste the code below to help me to give any changes needed to change for accessing my login process….

    `
    * WordPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each
    * a unique prefix. Only numbers, letters, and underscores please!
    */
    $table_prefix = ‘wp_’;
    define( ‘WP_HOME’, ‘http://inspiringinfo.co.in’ );
    define( ‘WP_SITEURL’, ‘http://inspiringinfo.co.in’ );

    define(‘FORCE_SSL_ADMIN’, true);
    define(‘RELOCATE’,true);

    /* That’s all, stop editing! Happy publishing. */
    if ($_SERVER[‘HTTP_X_FORWARDED_PROTO’] == ‘https’) $_SERVER[‘HTTPS’]=’on’;

    /** Absolute path to the WordPress directory. */
    if ( ! defined( ‘ABSPATH’ ) ) {
    define( ‘ABSPATH’, dirname( __FILE__ ) . ‘/’ );
    }

    /** Sets up WordPress vars and included files. */

    now i could not see my posts in my site – heatherielove.in

    Please help

    fortunately my site heatherielove.in is working again…please help me with inspiringinfo.co.in

    when i did some changes it got impacted on my heatherielove.in site as i am using same host for both the sites…

    Again i could see log in problem in my inspiringinfo.co.in ….no login page to be seen

    can you let me know stepwise process… the link which you gave me is slight confusing as it affected my heatherielove.in site

    tell me the process of changing from https to non ssl http …and my sites are in same host

    define( ‘WP_HOME’, ‘http://inspiringinfo.co.in’ );
    define( ‘WP_SITEURL’, ‘http://inspiringinfo.co.in’ );

    define(‘FORCE_SSL_ADMIN’, true);
    define(‘RELOCATE’,true);

    /* That’s all, stop editing! Happy publishing. */
    if ($_SERVER[‘HTTP_X_FORWARDED_PROTO’] == ‘https’) $_SERVER[‘HTTPS’]=’on’;

    Are these added by you or were there previously?

    had been added by me…but as this change was hampering on my other site …so i removed now…

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.