• Resolved TimHardisty

    (@timhardisty)


    I have been trialling this plugin since being advised to move away from “share and follow”. I’m also trying to ensure browsers are completely happy that my site is secure by adding a proper SSL certificate etc.

    I am not an expert, but it seems that Super Socializer embeds a lot of “http://” links – the heateor website itself is not https.

    Is this going to be sorted? Or can I fix it somehow?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor Heateor Support

    (@heateor)

    I have been trialling this plugin since being advised to move away from “share and follow”

    Sorry, we are not sure what you are talking about. Who advised you to move away from “share and follow” and which “share and follow”? Our plugin’s?

    I am not an expert, but it seems that Super Socializer embeds a lot of “http://” links – the heateor website itself is not https.

    https is necessary if your website have login system or it accepts credit card information from users. Our support website has neither of this required. That’s why we have kept it http. And we are sure this won’t cause any trouble to your website. Let us know any specific issue you are facing.

    “Share and Follow” was a plugin that has been withdrawn from WordPress due to unfixed security vulnerabilities; I have been trialling yours as an alternative.

    My website is secured using https. Of course the website needs login – its WordPress!! Google Chrome, for example, expects https to get the green “secure” icon. Any link within the website that is then not https will not give the “secured” icon. You get an “i”.

    It is your plugin that does this due to “hidden” links to non-https websites.

    You can look at my development/test website and inspect the source to see what I mean.

    https://diskstation.jti.uk.com

    Oh – and google “google https” to see what I mean

    Plugin Contributor Heateor Support

    (@heateor)

    My website is secured using https. Of course the website needs login – its WordPress!

    We were talking about our support website because you mentioned – “the heateor website itself is not https”

    It is your plugin that does this due to “hidden” links to non-https websites

    See the screenshot of your website below:

    The highlighted message in the browser console is the only message regarding insecure content and that is due to an image at your webpage being loaded over “http” which does not belong to our plugin.

    Oh – and google “google https” to see what I mean

    We know this very well and we deal with this everyday.

    OK…am now confused as only saw this after activating your plugin. I was able to “prove” this by deactivating and reactivating…but now it appears to behave whatever I do. I will investigate further and report back!

    Plugin Contributor Heateor Support

    (@heateor)

    The insecure content url (url of the image) is clearly of your website’s Upload folder. It’s not related to our plugin.

    I cannot explain this, but I 100% accept it is not your plugin – apologies.

    I have not changed the logo nor any other of the trial/dev site WordPress settings yet for some reason it decided to serve up some links as non https. This has now stopped happening so who knows what I did.

    Sorry to have troubled you.

    Plugin Contributor Heateor Support

    (@heateor)

    It’s okay.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Not secure!’ is closed to new replies.