Support » Plugin: HandL UTM Grabber » Not saving UTM_SOURCE when including slash

  • Resolved checklist.com

    (@checklistcom)


    Hi,

    I have installed this great plugin and it works fine for most URLs capturing UTM_SOURCE properly.

    I have found that when using a URL that ends with a slash as above, it does not store the UTM_SOURCE in the cookies. The issue is fixed if I remove the slash just before the ?utm_source= . Since I have hundreds of URLs in different campaigns it is impossible for me to change them all.

    Any idea how to troubleshoot?

    Thanks!

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Haktan Suren

    (@haktansuren)

    Hi @checklistcom
    The proper way of having get parameters is actually with slash. Without slash, question mark becomes part of the page slug. Please see here for more https://stackoverflow.com/a/1617074

    checklist.com

    (@checklistcom)

    Thanks so much for your answer. But that is exactly the point I was making: it works only WITHOUT the slash. You can try for yourself and see that the UTM_SOURCE is saved in cookies when you DON’T have the slash (which is against the spec).

    Thanks again for helping out.

    Plugin Author Haktan Suren

    (@haktansuren)

    Hmmm, i think this is related with your server settings. Can you check .htaccess file maybe you can find something there related to this?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Not saving UTM_SOURCE when including slash’ is closed to new replies.