Support » Plugin: BackWPup - WordPress Backup Plugin » Not running on new hosting server

  • Resolved Bike Gremlin

    (@bikegremlin)


    Great plugin, great job on making it. 🙂

    However, after moving to a new hosting, I’m having problems. Whenever I run a job, it shows errors of running out of memory. Tried giving the WP as much as 1GB of RAM and it still won’t work.

    PHP 7.2
    WP 5.1
    LiteSpeed server (and caching plugin used)
    MariaDB

    Could any of these be incompatible, or is it down to the hosting provider?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support duongcuong96

    (@duongcuong96)

    @bikegremlin
    Please show me your server configuration by go to BackWPUp -> Settings -> Infomation -> and press “Get debug info”
    Thank you!

    WordPress version: 5.1
    BackWPup version: 3.6.8
    PHP version: 7.2.15 (64bit)
    MySQL version: 10.2.21-MariaDB-cll-lve
    cURL version: 7.62.0
    cURL SSL version: OpenSSL/1.0.2k
    WP-Cron url: https://www.ivetamakeup.com/wp-cron.php
    Server self connect: Response Test O.K.
    Document root: /home/ivetamakeup/public_html
    Temp folder: /home/ivetamakeup/public_html/wp-content/uploads/backwpup-dbad38-temp/
    Log folder: /home/ivetamakeup/public_html/wp-content/uploads/backwpup-dbad38-logs/
    Server: LiteSpeed
    Operating System: Linux
    PHP SAPI: litespeed
    Current PHP user: ivetamakeup
    Maximum execution time: 90 seconds
    BackWPup maximum script execution time: 30 seconds
    Alternative WP Cron: Off
    Disabled WP Cron: Off
    CHMOD Dir: 0755
    Server Time: 17:7
    Blog Time: 18:07
    Blog Timezone:
    Blog Time offset: 1 hours
    Blog language: en-US
    MySQL Client encoding: utf8mb4
    PHP Memory limit: 512M
    WP memory limit: 40M
    WP maximum memory limit: 512M
    Memory in use: 58.25 MB
    Loaded PHP Extensions:: Core, PDO, Phar, Reflection, SPL, SimpleXML, bcmath, bz2, calendar, ctype, curl, date, dom, enchant, exif, fileinfo, filter, ftp, gd, gettext, gmp, hash, iconv, imap, intl, ionCube Loader, json, libxml, litespeed, mbstring, mysqli, mysqlnd, openssl, pcntl, pcre, pdo_mysql, pdo_sqlite, posix, readline, session, shmop, soap, sockets, sqlite3, standard, tidy, timezonedb, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, zlib

    After some testing, provider’s tech support said that on their server, it works only with PHP 5.6 and 7.3.

    Switching to PHP 7.3 seems to have solved the problem.

    Didn’t try going with “newer” PHP since I thought it could only make things worse, while 5.6 support is abandoned by WP this year for all I know, so didn’t try that either.

    Sorry to have bothered You and taken Your time. Seems it’s the provider’s setup that’s causing problems, from what I have seen so far.

    As far as I’m concerned, this whole thread can be deleted (or left if someone has similar problems, to not post the same question).

    Veerotech reseller hosting, and from what I understand, they are working to see what causes other PHP versions to not let this plugin work and fix that.

    • This reply was modified 2 weeks, 2 days ago by  Bike Gremlin.
    Plugin Support duongcuong96

    (@duongcuong96)

    @bikegremlin
    Great to hear you have resolved the issue 😀

    Btw, If you find BackWPUp is useful for you, we would really appreciate if you leave a positive review and rating.
    This would encourage us to develop new free features and provide free support 😀
    https://wordpress.org/support/plugin/backwpup/reviews/

    Thank you very much for the support 😀

    Cheered to early. :/

    The plugin runs without showing any errors, but doesn’t save several directories (wp-content etc.).

    Also, database export doesn’t seem to work when imported on another hosting server.

    Seems to be the host server/setup problem.

    Trying to get it sorted, but don’t think the problem is BackWPup related anymore.

    Will be sure to write a review, after this whole ordeal is finished. So far:
    1 perfect migration using BackWPup, with 3 different websites. And now stuck. 🙂

    Plugin Support duongcuong96

    (@duongcuong96)

    @bikegremlin
    Maybe it does not help much but please try using Tar instead to see if there is any difference 🙂
    And I really think there is server issue too, anyway, please keep me updated 🙂

    Didn’t work either.

    Doesn’t save the files, just DB export, plugin list etc.

    Tried with backup to DropBox, in case it’s some write protection, but still won’t backup all the WP files.

    As far as hosting provider’s tech. support is concerned: their server works fine, I should “see with the vendor” what causes the plugin to not work properly. 🙂

    I do have a way to make backups using cPanel, at least, so no worries with that (tested restoring them to two different hosts – worked). However, I liked BackWPup option to save database, root dir. files and current year’s files directory only, like a sort of an “incremental backup” – faster, smaller, keeping it up to date.

    Am curious, would like to get it to work, but not sure it’s worth bothering both You and host’s tech support. Using FTP for “incremental” file backups seems like an OK solution – not an automated one, but should be fast.

    Bike Gremlin

    (@bikegremlin)

    Question:

    Which PHP (7.3) extensions does this plugin use?

    I realised that “defauld” PHP setup on hosting server has most of extensions disabled (probably with a good reason). For another plugin, I just had to “add” “imagick” extension to make it work.

    Don’t think it would be wise to tick adding all the offered extensions, but a list of those used by this plugin could help me see if one, or more are “missing”, add them, and perhaps see it working (again).

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.