Support » Plugin: Custom Permalinks » Not rendering Yoast breadcrumbs correctly

  • davidkneale

    (@davidkneale)


    Hi there.
    I’m using Yoast for my site breadcrumbs and placing them onto pages/posts via the use of a PHP code widget. I am using Custom Permalinks to change the slug of a portfolio page to present it as the child of a regular page, however the breadcrumb is still showing ‘portfolio/post-name’ instead of ‘page-name/post-name’.

    I have disabled my theme breadcrumbs, and have tried both Post Name and Custom Structure for my Permalinks settings.

    Do you have any advice on a possible fix for this?

    Thank you.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Sami Ahmed Siddiqui

    (@sasiddiqui)

    @davidkneale

    Please provide your site link and the code which you are using to print the breadcrumb.

    Thanks,
    Sami

    davidkneale

    (@davidkneale)

    Hi Sami.
    Thank you very much for your reply.

    Here is a link to a development page: https://www.new.africanwildlifesafaris.com.au/kenya/amboseli-chyulu-hills-and-tsavo/

    Password: aws2017

    You can see the difference between the slug and the breadcrumb.

    To place the breadcrumbs on the page:
    1) I have installed the plugin ‘PHP Code Widget’
    2) I have created a widget and inserted the code:

    <?php
    if ( function_exists('yoast_breadcrumb') ) {
    yoast_breadcrumb('
    <p id="breadcrumbs">','</p>
    ');
    }
    ?>

    3) Have placed widget shortcode onto the pages/posts.

    The breadcrumb works fine with page slugs that I have not modified.

    Thank you very much for your help.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Not rendering Yoast breadcrumbs correctly’ is closed to new replies.