Support » Plugin: Classic Editor » Not rendering Vimeo videos?

  • Hi, I have a client website running on WP 4.9.9 with a custom bespoke theme. It’s using YouTube and Vimeo embeds in various places.

    On a development clone, after upgrading to WP 5.0.3, using the Classic Editor, the Vimeo videos are no longer rendering. They’re not rendering in the edit screen, nor on the front-end after publish, it just prints the URL. The YouTube embeds still render as usual in the edit and front-end.

    I’ve replicated this on a vanilla 5.0.3 install with all plugins deactivated, and just Twenty Nineteen theme and Classic Editor plugin. It does the same thing.

    An example video working on 4.9.9, but not 5.0.3/Classic Editor is https://vimeo.com/240911801

    Is there a known bug with Vimeo embeds?

    Thanks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Andrew Ozz

    (@azaozz)

    Yeah, happens here too, but inconsistently. However I see some kind of very blurred poster image or first frame.

    When it fails I can see couple of js errors coming from Vimeo player (from the iframe), both in the editor and the front-end:

    
    player.js:2 Uncaught TypeError: Cannot assign to read only property 'play' of object '#<HTMLMediaElement>'
    
    240911801?app_id=122963:265 Uncaught TypeError: VimeoPlayer is not a constructor
        at HTMLScriptElement.script.(player.vimeo.com/video/anonymous function) (https://player.vimeo.com/video/240911801?app_id=122963:265:36)
    

    The same happens when using the embed code copied directly from Vimeo. Assuming they have some …problems that they will fix 🙂

    • This reply was modified 2 years, 1 month ago by Andrew Ozz.
    • This reply was modified 2 years, 1 month ago by Andrew Ozz.
    Thread Starter crdunst

    (@crdunst)

    Hi Andrew, thanks for looking into it.

    I’ve just spent all morning, trying it out on a fresh install, and a clone of my client site where I had the problem.

    Everything was inconsistent to start with – creating new posts allowed me to embed the video normally, but trying to add videos to existing posts (that existed pre WP5) was hit and miss. I tried taking all of the content from the old post, including the featured image and tax settings and applying them to my new post, but that still allowed the embed to generate on the new post.

    Cloning the old post, and trying to embed in that had no luck either, so I started to think it was something in post meta or transients of old posts.

    On my cloned site, I installed https://wordpress.org/plugins/rvg-optimize-database/, and in the settings deleted transients and selected ‘Clear oEmbed cache’. Ran the optimisation. This time my old posts on my site clone (separate server) allowed the embed to generate. “That’s great” I thought, I’ve cracked it. Unfortunately when I tried this on my original site on my local machine, installed the same plugin and optimised, my local old post still doesn’t let me generate the embed.

    When the embed doesn’t generate by the way, I’m seeing no errors in Chrome console or debug logging.

    I literally give up. I’ll update the clients site and recreate the new posts with vimeo in them if I have to. I just wanted to report back in case you hear of anything similar.

    If you’d like a copy of my local install for testing (there’s no personal data or anything confidential in it), feel free to email me – check my profile for our domain, and it’s chris@ – I can dropbox you a copy.

    Thanks again

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Not rendering Vimeo videos?’ is closed to new replies.