• So I have s2member installed.. have it setup so far.

    My issue it, it redirects fine for pages like contact, about, etc.. I’m assuming ACTUAL pages on the wordpress installation.

    I have a real estate plugin where it generates listings based on the IDX pluging.. Basically I don’t want people to be able to look in there or do any search without being registered.

    My issue is, whenever i restrict access via URI, it does not redirect and instead just shows a blank white page.. but only for /idx/

    Any help with this?

    The site is http://www.phillysuburbanhomes.com – if you click on “latest listings” you will see that when I have it restricted it shows white and does not redirect.


Viewing 15 replies - 1 through 15 (of 15 total)
  • Have you set up the Membership Options page?

    By default, s2Member redirects a restricted post or page to that. If you haven’t set it up, then it can’t redirect.

    Yeah, I have it set up.. It works for everything else but the IDX 🙁

    That’s the issue I’m having which I don’t understand why.

    In that case, have you been editing any PHP files somewhere? Because the main cause of a white screen of death is a PHP file with a blank space before the first PHP or after the last PHP tag.

    Nope, I have not. I even completely deleted the plugin and re-installed it (and i made sure to disable the anti-delete security feature before doing so)

    OK. On re-reading your first message, you talk about “ACTUAL pages on the wordpress installation.” I had assumed that the fact you were using a WordPress plugin to import your listings meant that that puts them on an actual WordPress page. But maybe it does not.

    If not, then using the URI function won’t work. Instead, s2Member treats non-WP content as Downloads. So you’d then need to store your imported listings in the appropriate downloads folder to protect it, and then customize other behavior using s2Member’s Download Options.

    These pages change, listings are added and removed everyday.. Will this work? I don’t really understand what you mean by this.

    It blocks the uri when not logged in, and allows it when I am logged in.

    So it knows that anything with ‘idx’ in the uri should be blocked, it just doesn’t redirect at all.

    When you say “these pages change,” are they WordPress pages, or are they pages created on the same domain that stand outside WordPress?

    If the latter, then you need to treat them as downloads, and you’ll get the behavior you expect. If the listings are on regular WordPress pages, then I thin your next steps will be to (a) re-save permalinks, and (b) check whether you have a theme or plugin conflict.

    They are pages that still have the same domain, still phillysuburbanhomes.com

    Just goes to phillysuburbanhomes.com/idx

    I just want anything that has that in the domain to be blocked unless logged in and redirected to the register page.

    I can unblock this page if it would help you see it.

    Sorry, but that’s not actually what I’m asking. I understand that all the pages are on the same domain, and therefore appear as on the same site.

    But there’s a difference between your website and your WordPress installation. Websites can be created in many different ways, of which WordPress is just one. Some websites are centered on WordPress but also use content that, technically, stands outside WordPress.

    By this I don’t mean that such content is drawn from sources outside of WordPress. I mean that, when it is accessed by a user on the website, it is outside WordPress.

    For content to be in WordPress, it would have to show on a WordPress post or page. If it’s not in a WordPress post or page, it’s outside WordPress.

    So far as s2Member is concerned, if you’re trying to protect content within WordPress, using the URI method should work. But it won’t work if the content stands outside WordPress. For that content, s2Member requires that you treat the content as a download, even if it doesn’t seem that way to you.

    So does your content appear on a WordPress post or page, or somewhere else. If it’s the latter, then you will need to treat it as a download in s2Member to get content protection and redirection working as you want.

    Thank you for the help, I am starting to get what you’re saying.

    So how do I go about making this work? The way the plugin works is by getting listing information from some real estate source and provides it to the site..

    Is there a way?

    Yes, there is deinitely a way. I have a ton of content that sits outside WordPress, but s2Member still protects it perfectly. In fact, that feature is one of the main reasons why I use s2Member: most other membership plugins can’t do this.

    But I still don’t know if, by “Provides it to the site,” you mean that it’s in WordPress or not.

    If it’s not on a WordPress post or page, you need to start by placing whatever your content is in a folder that s2member protects. See s2Member -> Download Options -> Basic Download Restrictions.

    Then go through the next three sections on the Download Options page. Then remove your URI restriction. Then test!

    Yes, the content is outside of wordpress and gets pulled into wordpress by the IDX plugin.

    I will take a look in the backend, in the downloads section and see if I can figure it out.

    I’m confused now, can’t seem to figure it out. I think the content may come in as some sort of Iframe? With stored css styling built into the plugin.

    Have a look at s2Member -> Download Options -> Preventing GZIP Conflicts on Server.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Not redirecting with IDX plugin’ is closed to new replies.