Support » Plugin: PayPal IPN for WordPress » Not receiving ipn anymore

  • Resolved jules1234

    (@jules1234)


    Hello everybody,
    I have a problem with my IPN PayPal plugin. I saved the listener within the sandbox seller account but no ipn is sent. A few days ago it sent the ipn after a test-purchase but since a few days ago it doesn’t sent them anymore. I also looked at the ipn-history in PayPal, where I can see that ipns were sent but they are not listed in my plugin. What can I do to fix that error?

    Kind regards,
    Julia

Viewing 5 replies - 1 through 5 (of 5 total)
  • Oliver

    (@angelleyesupport)

    Hi @jules1234 ,
    Thats interesting, Can you look at the PayPal Ipn settings and see if you may have enabled IPN sending or not?

    http://prntscr.com/mds4mt

    I said that becasue I just setup that and performed an order using PayPal for woocommerce express checkout. The IPN received in 10 seconds after it reached the order received page. Please see this.
    http://prntscr.com/mds5et

    So, I am curious how you are processing the Payments ? To test IPN reception, did you tried PayPa Ipn simulator
    https://developer.paypal.com/developer/ipnSimulator/

    Please try to send a dummy IPN using this simulator to your IPN URL , if that is received then the plugin is not the issue but something else may not be working there.

    Please give that a shot and let me know if you still have any other questions or concerns.

    Thanks!

    Hi Oliver,
    thanks for your quick reply. 🙂

    Yes as you can see I enabled IPN sending: https://prnt.sc/mdsk32
    I also made some test-payments and PayPal says that the following IPNs were sent: https://prnt.sc/mdslm5
    But I only received them: https://prnt.sc/mdslre

    I added the IPN listener in the sandbox-seller-account I created and tested it with my sandbox-buyer-accounts I created. The strange thing is that it worked for a few testings. As you recommended I tested the IPN reception within my IPN simulator (as you can see in the plugin-screenshot above I already did that a few days ago and it worked) but now it also didn’t work anymore.

    Do you have any idea what’s the problem here?

    Thank you!

    Oliver

    (@angelleyesupport)

    @jules1234 Well, That’s really odd that all in a suggest it stoped getting hits.
    Do you have any other site hosted on a different server? Can you try our plugin over there and see if you are getting the IPN data from simulator?
    If the answer will be Yes, Then something on your site is not working well. It could be a plugin or some PHP error which might be giving hard time.

    To debug that, you can turn off all extra plugin except for woo, our PayPal plugin and IPN then try to run the simulator. Also, check if you are running some cache plugins? Clear their cache and turn off cache system temporarily and see if that makes things better?

    Please run those and let me know what changed after that?
    Thanks!

    Hi Oliver,

    thanks for your help! I found the error: I implemented some php-code to have some page-restrictions, so that only users who have already paid can see certain pages. However, I forgot to allow users who are not logged in to go to the paypal-listener-url. I guess that’s why the IPN couldn’t arrive. Now it seems to work just fine.

    Thanks again!

    Plugin Contributor angelleye

    (@angelleye)

    Glad you got it worked out!

    If you have a moment to leave a review for the plugin it would be greatly appreciated. Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.