Support » Plugin: Google Customer Reviews for WooCommerce » Not receiving emails

  • Resolved daveaevion

    (@daveaevion)


    I have installed this plugin and set up my Google Merchant account. The survey opt-in form is displaying correctly after items are purchased, but no emails are being received after opting in. I have set the EDD to both 0 and 1 days (in case 0 doesn’t work), and nothing has worked for either.

    In my Google Merchant account, there is no data for surveys sent or received, or even for opt-ins received, which is odd because the surveys are definitely popping up, and I have requested multiple surveys with different email accounts.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Contributor natekinkead

    (@natekinkead)

    How long have you waited after filling out the opt-in form? I assume you used an email different from the one associated with your Google Merchant account?

    I will have to check later if another account is showing data about opt-ins received and surveys sent.

    Hi Nate. Thanks for the fast response! I have tried 3 different email accounts. One was the same as the merchant account but the others were different and none have received surveys after saying “yes” to opt in.

    I have waited a few days after the estimated delivery date and never received emails. Of note I was using another plugin that customized the order numbers and that could have messed up google. I’ve since deactivated it and have tried again with different email accounts. It hasn’t been a full day yet, but my merchant account is still not even showing that any opt ins have been received.

    I’ve added a link to my store in case you’re curious to see the source code. It looks correct to me. I really appreciate your assistance!

    https://store.nursejanx.com/

    • This reply was modified 3 years, 1 month ago by daveaevion.
    Plugin Contributor natekinkead

    (@natekinkead)

    I’m not sure why changing the order number would affect it. Really, I don’t know what about the plugin would have any effect on whether or not Google sends emails (of if Google receives the opt-ins from Google’s own popup form).

    All the plugin does is implement Google’s javascript code on the site as per their documentation. If you see the popup, then the plugin is working. Past that, it would have to be a problem with the Google Merchant Center account.

    Let me know after you’ve waited enough time if you get it or not… or if you find out what the issue is with the account.

    I think you’re correct, Nate. I do appreciate your help. The plugin is correctly displaying the pop-up, and the badge, so like you said, the ball is in Google’s park.

    I’ll update back if I ever figure out what the problem is.

    Plugin Contributor natekinkead

    (@natekinkead)

    Thanks. I hope you find the solution.

    Awesome, I’ve started receiving the emails. Great plugin, thanks all!

    Plugin Contributor natekinkead

    (@natekinkead)

    Great, I’m glad it’s working well for you!

    @daveaevion did you do something to receive emails? or it just need few days in google to resolve that?

    Plugin Contributor natekinkead

    (@natekinkead)

    There is a delay of a number of days before Google will send the emails. This is to allow time for the product to be delivered. Have you started receiving the emails yet?

    @natekinkead yes bro it come I have in plugin set 1 day delay but mail come after 3-4 days 🙂 its okay, but I complete and send review, and cant see it in badge … I cant see it in google merchant center too, I know it has nothing with plugin now, but do you have any idea what can be problem there? or just google take few days to check spam or something?

    Plugin Contributor natekinkead

    (@natekinkead)

    I don’t know why they would add extra days to delay the email… maybe just to give the customer some time to use the product enough to be able to give a review.

    With the review not showing up, I’m guessing it has to go through some moderation (whether using AI or manually done). That, and it could also just need time for database propagation/indexing.

    @natekinkead thank for your time and help… it great plugin and works 100% just google need few more days…

    for everybody just wait few more days in every action google takes

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Not receiving emails’ is closed to new replies.