Support » Plugin: Forminator - Contact Form, Payment Form & Custom Form Builder » Not Receiving Email Notifications

  • Resolved yieldway

    (@yieldway)


    Hello Support,

    I’m using the plugin since a year without any issue, thanks.

    Though, 2 days ago I changed email address on one of the Forms but still today, email notifications are going to the old email address instead of the new one that I have updated in the Forminator form.

    Is there something else I have to do to make this update work please?

    Looking forward to your response …

    Have a nice day ๐Ÿ˜‰

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @yieldway

    Sorry to hear you are having this issue.

    Can you confirm if the plugin saved the new email settings?

    As long the plugin saved the new email in Forminator > Form > Email Notification it should work.

    If so, also please try to flush all caches and see if makes any difference.

    Let us know the result you got.
    Best Regards
    Patrick Freitas

    Thread Starter yieldway

    (@yieldway)

    Good Morning Patrick,

    Thanks for getting back to me.

    I confirm that the plugin saved the new email settings. It’s the first thing that I checked.

    I’ve also flushed the cache but it is still not sending notifications to the new email address.

    Plugin Support Nebu John – WPMU DEV Support

    (@wpmudevsupport14)

    Hi @yieldway,

    That’s strange, once the email settings are saved the notifications should be received at the new email ID. Can you please export the form and share it here using Google Drive or DropBox so that we can take a closer look at this?

    Reff: https://wpmudev.com/docs/wpmu-dev-plugins/forminator/#import-export

    Can you please confirm if you have cleared the object cache at the server end as well?

    Looking forward to hearing back from you.

    Kind Regards,
    Nebu John

    Thread Starter yieldway

    (@yieldway)

    Hello John,

    indeed that seems strange to me as well.

    Anyway, here is the link to the exported form: https://drive.google.com/file/d/1zuuvDONJ1YwVQRzm92Qnw_M1TYXC7w0J/view?usp=sharing

    NOTE: Email being received in old email account is also messing … not getting the details of the different services the client paid for …

    Thread Starter yieldway

    (@yieldway)

    Oh, and YES I have cleared cache!

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @yieldway

    Thanks for sharing the form.

    The address that it shows me as the one for notifications there is currently the “jaXXXe.eXXXs@cryXXXXi.com” (I hope you can recognize it in this form) – would that be correct?

    I checked the form and I see nothing there that could possibly alter/change that e-mail and if this is correct address then it means that it got correctly set in form settings and Forminator itself will attempt to use it.

    I’m wondering though if there maybe something on site that could possibly be overriding this. Do you have any other form-type plugins active or some sort of SMTP plugin enabled (with SMTP configuration set up)? Or are you using any solution to send mails via 3rd-party services such as, for example, MailGun or similar?

    Kind regards
    Adam

    Thread Starter yieldway

    (@yieldway)

    Yes indeed I have updated to jaXXXe.eXXXs@cryXXXXi.com and that’s what you see. The issue is that email notifications are not going to that email account but to the old one …

    The only plugin that is on the website is Wp Super Cache and UpdraftPlus.

    Before I did that change of email address everything was working perfectly well, I’m very annoyed by that and don’t know what to do …

    • This reply was modified 1 year, 4 months ago by yieldway.
    Plugin Support Pawel – WPMU DEV Support

    (@wpmudev-support9)

    Hello @yieldway !

    I hope youโ€™re having a great week.

    It’s definitely very odd to see something like this to happen. I’m thinking – maybe the server itself is overriding that and still sending to the old address?

    I would suggest to try the following steps:

    1. Install our plugin Branda (https://wordpress.org/plugins/branda-white-labeling/) which has an option in Branda >> Emails >> SMTP to setup sending through a specified external email service. The setup is very similar to the setup of an email app and the credentials and details used are most often the same.

    2. Branda also has an option to save email logs – please enable those as well and test the email notification once more to see whether they arrive correctly now.

    If this helps, you can either keep the Branda setup or contact your hosting provider to investigate the issue on their end and see whether you can change the settings on the server, without using a plugin.

    Kind regards,
    Pawel

    Thread Starter yieldway

    (@yieldway)

    Hello Pawel,

    thanks for the above suggestion. I’m going to try it, and later come back here to let you know if it has solved my issue.

    Have a great day ๐Ÿ˜‰

    Plugin Support Nithin – WPMU DEV Support

    (@wpmudevsupport11)

    Hi @yieldway,

    Sounds good, please do let us know how that goes. Have a nice day ahead.

    Kind Regards,
    Nithni

    Thread Starter yieldway

    (@yieldway)

    Hello Nithni and other staff reading this ๐Ÿ˜‰

    My plugin is now working very well!

    Thank you so much for your kind assistance.

    Have an axcellent weekend ๐Ÿ™‚

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Not Receiving Email Notifications’ is closed to new replies.