WordPress.org

Support

Support » How-To and Troubleshooting » Not receiving email notification of new comments

Not receiving email notification of new comments

  • laowaichinese
    Member

    @laowaichinese

    I’ve seen some other posts on this but not about the current version of WordPress that I’m using (2.2.1).

    The title tells it all: I’m not receiving an email notification of a comment held for moderation nor a new comment posted to the site, although both of those boxes are checked in Options > Discussion.

    Interestingly, the email address (a forwarding account set up on my server) seems to be working fine because I have the WP-Contact Form plugin (http://www.douglaskarr.com/projects/wp-contactform/) sending to the same address and I DO get those emails.

    Any thoughts?

Viewing 15 replies - 31 through 45 (of 70 total)
  • lisar915, did this problem specifically start happening after upgrading? There are any # of reasons for this issue, and many aren’t specific to WordPress. If it is the problem described in 5294, instead of changing the code, install http://trac.wordpress.org/attachment/ticket/5294/no-sender.php as a plugin.

    Actually, today I have started receiving comment notifications via email, so perhaps it did help.

    Thanks again.

    laowaichinese
    Member

    @laowaichinese

    lloydbudd,

    I’m starting to think my server is cursed. First of all the plugin called “no sender” that you recommended seems to be broken. It fails to activate and in my plugins menu the title of it appears as:

    <a href="http://blog.ftwr.co.uk/wordpress/" title="Visit plugin homepage">pjw-wp-phpmailer-nosender

    I’ve also added the forwarding address wordpress@<mydomain> and can receive emails to that address via a contact form, but still no comment notifications.

    Any suggestions?

    Hi I am on version 2.3.1 on my prod and dev environments. Only the administrator comment notification is not working for me. And it is only not working on my prod environment. The test environment is working fine. The only difference is the prod is running windows 2003 server and dev is running windows 2000. I looked at all the prior suggestions and could get nothing to work. This has been an issue ever since I first starting using wordpress and could not find a fix. Any suggestions?

    Thanks
    J

    I’ve been running without problems for months. As soon as I upgraded from 2.3 to 2.3.1 I stopped receiving emails when users make comments (whether or not the comment goes to moderation). The related checkbox in the options is checked. I tried checking it and unchecking it. Adding an email address wordpress@mydomain.com did not fix the issue. I will try the plugin mentioned above.

    khristopher
    Member

    @khristopher

    I tried installing the plugin. That did not work.
    I tried removing that line of code from pluggables.php, that also did not work.

    I’m not sure what the first option is talking about. I don’t have an address wordpress [at] khristopher.com (that’s my domain)
    My comments are supposed to go to: admin [at] khristopher.com

    I really don’t know what to do here, any advice would be great. My email is not being hosted by my host, it’s on a third party host.

    Same here. Removed the line from pluggables.php, installed the plugin, nothing seems to work. Also, creating an email uses could not be the solution; my blog domain is blog.marionogueira.com. I can create email accounts on marionogueira.com. However, the pluggables.php will try to force the “send user” to something like wordpress@blog.marionogueira.com.

    Couldn’t this be an admin option, not “guessed” by the script?

    Oh, and I only noticed this behaviour after the 2.3 to 2.3.1 upgrade… 🙁

    Is there any new info on this question?

    Thanks

    I’m running 2.3.1, also on Bluehost, and I had this same problem. I was previously running a 1.x version on this same host, and I did not have the problem until I upgraded.

    I tried re-saving the options as mentioned upthread. That did not fix it. The no-sender.php plugin did not fix it either.

    I commented out line 228 in pluggable.php as described in bug #5294 and now I get the emails. However, now the emails don’t arrive from my WordPress administrator persona. (This is an expected side effect of this change.) Instead, they come from my main Bluehost administrator account (<cpanel username>@box238.bluehost.com). But at least I get them now, so I can live with it.

    I don’t know for sure, but my educated guess is that Bluehost is doing some kind of filtering on outbound email even if that option is turned off in CPanel.

    jacknjeannie
    Member

    @jacknjeannie

    I am running WP 2.3.1, Bluehost.

    Here’s what I did that fixed my problem:
    http://www.jacknjeannie.com/wordpress/2007/12/03/wordpress-not-sending-out-email-notifications-of-new-comments/

    What I found is:
    1. Remove line – didn’t work
    2. Add wordpress@domainname.com – didn’t work
    3. Remove line, install Comments Notifier (& configure) – works
    4. Add wordpress@domainname.com, install Comments Notifier – works

    Your mileages may vary. Good luck!

    jballinger
    Member

    @jballinger

    The pluggin worked for me! Thanks for posting this.

    jacknjeannie
    Member

    @jacknjeannie

    glad that worked for you 🙂

    wp 2.3.2 is not sending email notification for the new comments as well.

    Sorry, but I tried the php-send plugin and the comment notifier, as well as editing my pluggable.php file. Still nothing is working.

    Any thoughts/suggestions?

    Thanks.
    Lisa

Viewing 15 replies - 31 through 45 (of 70 total)
  • The topic ‘Not receiving email notification of new comments’ is closed to new replies.