Support » Fixing WordPress » Not receiving automated notification of new comments pending

  • I recently upgraded my blog to WP 2.7.1. Also changed the design template of my blog. In any case, I’m no longer receiving the automated message I used to get of comments pending (comments being held for moderation).

    Under the “Discussion Settings” category, I have the box checked that says “Email me whenever anyone posts a comment.” Also, the administration email I have listed inside my WP admin panel is the same email that I was using before I upgraded, so I’m wondering if I have to change something or turn something on inside my web hosting account for these notification emails to be sent to me?

    As it currently stands, I have to log into my WP admin panel to see if there are any new comments, whereas as before I got an automatic email telling me whenever new comments had arrived and I didn’t need to sign into my blog to find out.

    I looked for an answer to this question in the forums but couldn’t find one that addressed this particular situation. If there is already an answer to address this, if someone would be so kind as to point me in the right direction by posting the URL, I would greatly appreciate it since I’m not technically inclined.

    Thank you.

Viewing 14 replies - 1 through 14 (of 14 total)
  • I have the exact problem.
    I have worked for a week creating a new theme and everything works fine – no errors – and i payed attention not to do anything wrong and suddenly today i don’t get any notifications from post comments AND from the contact form. Is like it just stopped working…?!

    Also i spent 40 mins (by now) looking for other posts on this forum and all i find is non answered topics about this OR the idea to install different plugins to “force” WP to send notifications again. Is this ok i wonder…

    This should not be so hard. I’m having the SAME problem and I am running the most recent version of WordPress – 2.8.2
    It seems like there are a lot of people that aren’t receiving comment notifications. Has anyone figured this out yet??? Can we get an administrator to help with this as it is clearly a huge issue?

    Ok, so 2.8.2 did fix this issue. The messages were just coming to my SPAM folder in Gmail.

    We have been experiencing a similar problem, with the exception that we are not holding comments for approval, but instead have checked to receive an email any time there is a comment. We have seen these problems, in 2.8.3, 2.8.5 and 2.8.6 Did anyone resolve this problem?

    Have you ever received the emails? or did they stop with an update?
    If you’ve never gotten the emails, from what I understand, that could be an issue with your host

    I am having this issue as well. I migrated my blog to the cloud at the behest of my provider Laughing Squid (the cloud service is an offshoot of Rackspace) and ever since I did that, I have not received my comment administration emails as I did before and as I have specified in my WordPress installation. I’d love to know if and when somebody figures out how to iron this out.

    No answer on this yet?

    I am having the same problem.
    Seems there are multiple posts about this and no real solutions.

    Any updates? It’s a real problem!

    Same here team, I am on 2.9.1, and the problem persists- come to think of it when I moved over to Rackspace cloud…. Time to look into my database for issues I suppose….

    same here – migrated a 2.9.2 install to the rackspace cloudsites and ever since we get no comment notification emails. rackspace won’t touch it.

    I found this at laughing squid who appear to use rackspace cloudsites:


    Under point 12 they say:

    # Why am I not getting comment notification and other administrative emails? #

    Our Cloud mail servers check that a valid “from:” address is set when delivering mail generated by a script. The WordPress script sends some administrative email as ‘’ and if this email address has not been created in your control panel you will not receive these messages.

    The way to fix this is to create this address as either a real mailbox or as a forward to another address. Once you do this you should receive comment notifications normally.

    So, I created the wordpress@mydomain account but still no comment notifications coming through.

    I spoke too soon! The above fix from laughing squid actually works for me now on my rackspace cloud sites. yay!!!

    I can’t even save the option to receive mail. I check the box then save, and the check mark disappears after I hit save. I’m guessing it is for the reasons you state, since I changed my host recently. I have created wordpress@mydomain, and am waiting to see if it works. So far, no joy. I would like to know if others have this problem of not being able to save the option for receiving mail.

    I’ve been searching for a solution for this, too. So far none have worked. Have created a wordpress@mydomain address, but… still nothing.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Not receiving automated notification of new comments pending’ is closed to new replies.