Support » Plugin: Jetpack by WordPress.com » Not reading my site's traffic correctly

  • For some reason Jetpack isn’t reading my traffic stats correctly. I’m consistently in the multi-thousands in traffic, then overnight it’s barely registering 100 views.

    My google analytics and social shares are still consistent with my normal traffic but jetpack isn’t registering them.

    Suggestions?

    https://wordpress.org/plugins/jetpack/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Brandon Kraft

    (@kraftbj)

    Happiness Engineer

    Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.me/contact-support/

    The site is http://www.thelaughbutton.com

    Coincidentally, my ads have stopped showing up at the same time. I run 728×90 and 300×250 through google DFP (which work on other sites).

    I don’t know if its related, but in case this info helps you troubleshoot.

    Plugin Contributor Brandon Kraft

    (@kraftbj)

    Happiness Engineer

    That could be related. Our stats tracker uses both a piece of Javascript and an image tag. If something is conflicting on your site, it could disrupt the JS from executing as expected, which could impact both items. I’m not familiar with Google’s DFP, though reasonable to think it utilizes JS to load ads.

    I notice you had a recent jump up of stats—are the ads working again too? Are these numbers more like what you’d expect? If so, whatever was changed may have resolved both issues.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Not reading my site's traffic correctly’ is closed to new replies.