Support » Plugin: Wordbooker » Not Pulling Page Info

  • Resolved IILLC

    (@iillc)


    For some reason Wordbooker is not pulling fb page data. I can see in the logs that it is pinging them, but it is not populating anything except the group. These leaves only the group as an option and I can not access any of my pages to post to. Everything seems to be set up right and talking to FB it just can’t seem to retrieve the page data.

    Any help you can offer to resolve this would be great. I love this plugin!

    Cache Refresh	2014-02-21 12:32:07	Getting Pages administered by :	100001098742690	-
    Cache Refresh	2014-02-21 12:32:07	Page info for page ID 126044164078632		-
    Cache Refresh	2014-02-21 12:32:07	Page info for page ID 465249096844013		-
    Cache Refresh	2014-02-21 12:32:07	Page info for page ID 202431993132242		-
    Cache Refresh	2014-02-21 12:32:07	Page info for page ID 186307124744083		-
    Cache Refresh	2014-02-21 12:32:07	Page info for page ID 170595642985843		-
    Cache Refresh	2014-02-21 12:32:07	Page info for page ID 445200808860840		-
    Cache Refresh	2014-02-21 12:32:07	Page info for page ID 1483976335161277		-
    Cache Refresh	2014-02-21 12:32:07	Page info for page ID 509146325795015		-
    Cache Refresh	2014-02-21 12:32:07	Getting Groups owned or managed by :	100001098742690	-
    Cache Refresh	2014-02-21 12:32:07	Getting details for group :	1425877520963536	-
    Cache Refresh	2014-02-21 12:32:07	Group info for group ID 1425877520963536	[Correct Info]

    Here is the config info:

    Server Status
    Wordbooker: 2.2.1
    Wordbooker Code Base: 2.2.1 - Listen To Seashells They Know Everything
    Wordbooker Current Stable Release: Stable Version information not verified
    Blog Domain: www.campoutcolorado.com ( Domain )
    Wordbooker ID: 254577506873
    Wordbooker Premium Key: Not Activated
    Wordbooker Schema: 5.7
    WordPress: 3.8.1
    Table prefix: wp_
    PHP: 5.5.9
    PHP Memory Limit: 256M
    PHP Memory Usage (MB): 58
    PHP Max Execution Time: 600
    JSON Encode: PHP
    JSON Decode: PHP
    WP_HTTP Status: WP_HTTP can access Facebook - All is OK ( Response Time was : 0.306096076965 seconds )
    Curl Status: Curl is available and can access Facebook - All is OK, you can use the Curl Interface ( Response Time was : 0.259104013443 seconds )
    Curl Version: 7.24.0
    Facebook Interface: WP HTTP
    JSON Version: 1.2.1
    SimpleXML library: 0.1 (provided by PHP)
    HTTP Output Character Encoding: No Multibyte support
    Internal PHP Character Encoding: No Multibyte support
    64 or 32 bit: 64 Bit
    MySQL: 5.5.35-cll
    Database character_set_client : utf8
    Database character_set_connection : utf8
    Database character_set_database : latin1
    Database character_set_filesystem : binary
    Database character_set_results : utf8
    Database character_set_server : latin1
    Database character_set_system : utf8
    Database character_sets_dir : /usr/share/mysql/charsets/
    Database collation_connection : utf8_general_ci
    Database collation_database : latin1_swedish_ci
    Database collation_server : latin1_swedish_ci
    Server : Apache/2.4.7 (Unix) OpenSSL/1.0.1e-fips mod_bwlimited/1.4

    Thanks for your help!

    https://wordpress.org/plugins/wordbooker/

Viewing 6 replies - 16 through 21 (of 21 total)
  • Plugin Author Steve

    (@steveatty)

    I didn’t put the IDs into the Status dropdown but they are there on the Target Page dropdowns. I can code that change in but as I said I can’t troubleshoot your problem without getting an active session that I can work with so I can put debugs into the code that pulls the data from Facebook to work out why you are the only person being affected by this.

    Plugin Author Steve

    (@steveatty)

    Driving home this evening I had an idea.

    How do you feel about editing code?

    If you feel OK open wordbooker_cron.php (its in the wordbooker/includes direcory)..

    Find:

    $pages["name"]=$pageinfo->$page_access->name;

    and replace it with

    $pages["name"]=$page_access->name;

    I am comfortable with code. I went ahead and changed the line and that did the trick! Nicely done. Thanks a ton for the help.

    I have tested and it appears to be posting just like it did before.

    Thanks again!

    Plugin Author Steve

    (@steveatty)

    It’s my fault – I changed how I handled the Page details but never changed the non multibyte code – and your blog must be one of the few that doesn’t support multibyte at the php level.

    Interesting, I have heard the term but not sure what it is. I will have to read up on it.

    Is this something that was deprecated in php 5.5? Maybe that is the issue.

    Again, thanks for all your help!

    Plugin Author Steve

    (@steveatty)

    No its not something that was deprecated, its support for characters that take 2 or more bytes to define….

Viewing 6 replies - 16 through 21 (of 21 total)
  • The topic ‘Not Pulling Page Info’ is closed to new replies.