Support » Plugin: WP WDFY Integration of Wodify » Not posting “Today’s WOD”

  • Resolved ryanodon


    Hi there!

    I’m trying to show Todays WOD on the homepage of the site, but the shortcode [wdfywod] won’t post the wod from the current day. It will show the date, but not the WOD

    However, it seems to show older WODs just fine using the date attribute:
    [wdfywod date=”2017/01/25″]

    Is this an issue of the current content not being available? I’m trying to figure out why it wouldn’t show current posts. The content shows up in the Wodify app and I haven’t seen any other issues.

    Any help would be appreciated. Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author osti47


    This is hard to diagnose remotely of course. If it shows the date it seems to indicate that there is a WOD, otherwise the message would be “No WOD” or something like that.

    You could try to call your homepage with the ?updatewodcache parameter to ensure that this is not a cache issue (e.g. if your page is enter in your browser)

    Also please use the ignorepublishdate paramerter in the shortcode to test, if this is an issue: [wdfywod ignorepublishdate=”true”]

    If this does not help I suggest a remote session to check your Wodify API response. You can also try yourself, please make sure to set the parameters accordingly

    This should give you an xml view of your WOD.

    Thanks for the response!

    I have tried the ?updatewodcache parameter to no avail, as well as [wdfywod ignorepublishdate=”true”]. I’ve also tried calling specific programs with [wdfywod ignorepublishdate=”true” program=”CrossFit”] and double checked the case of the program name.

    Using the link provided I am seeing XML for both the date that is working and the one that is not. I tried to scan the XML to spot any differences between the two dates that might cause the issue, but there aren’t any that jump out. Is there anything in particular that needs to be enabled on the Wodify end?


    Plugin Author osti47


    can you please send me both xml files to stefan(at)

    Plugin Author osti47


    resolved with version 1.8.2

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Not posting “Today’s WOD”’ is closed to new replies.