Support » Plugin: Blog2Social: Social Media Auto Post & Scheduler » Auto-Posting not working

  • Resolved mike2972


    When a post is scheduled, the auto-poster status for this post is activated.
    When the scheduled time arrives, the post is automatically posted, but the post is NOT sent to Facebook and Twitter (I setup both networks).

    When I open the post editor, I see that the auto-poster is now deactivated, but it says: Shared: 0 times.

    Then I click “Advanced Config”, tick “enable Auto-Posting”, Select the Twitter profile, and then update the post.

    Now it says: Shared: 3 times.

    I only have 2 profiles. So Shared 3 times makes no sense at all.

    But again. Nothing is actually posted to Facebook or Twitter.

    When I click Custom Sharing & Scheduling -> Info on the post editor page, and click the green Share button, the posts are successfully posted to Facebook and Twitter. So the connection to these networks is good.

    I’s just the auto-poster that is not working. Please help me fix this.

    (Maybe the so called Best Time Manager is messing things up? I don’t even want that. I want to post immediately when the the scheduled post is published)

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support Blog2Social-Support


    Hello Mike,

    Thanks for reaching out.

    May I ask you which WordPress and Blog2Social versions you are currently using?
    Please be so kind as to make sure to use the latest versions.

    Do you receive any notifications in Blog2Social regarding your missing posts?
    If your content was not posted, it would be helpful if you could send me a screenshot of your notification details. You will find notification details if you follow this path in your Blog2Social dashboard in WordPress:
    “Social Media Posts” -> “Notifications” -> “Details”

    I’m looking forward to your reply.

    Thread Starter mike2972


    Hi, thanks for the quick reply.
    WP Version: 6.2
    Blog2Social: 7.1.1

    “Details” cannot be found on the “Notifications” page. The list is empty.

    But when I click “Share WordPress Content”, the list fills with all posts (scheduled, etc.). Then I can filter on Author, shared by user, etc.

    Which post do you want me to select? The manually to social posted post? Or the posts that are still scheduled?

    Anyway, there is no “Details” button or link.

    • This reply was modified 4 months, 1 week ago by mike2972.
    Thread Starter mike2972


    In the meantime, I updated WP to version 6.2.1 and I will se again this afternoon if this makes a change.

    Plugin Support Blog2Social-Support


    Hello Mike,

    Thanks for your reply.

    Did you tick the box “Apply best times” in your auto-post settings?
    If you want to share your posts immediately, I would recommend unticking this. Otherwise, your posts will be shared at the best times.

    As far as I can see in your screenshot, you have selected “Facebook” as filter. Please be so kind as to reset your filter by clicking on “reset” and choosing “shared to network”. After that, please check your notifications again.
    Please also check your “Scheduled Posts” and “Shared Posts” tabs in Blog2Social for these missing posts.

    I’m looking forward to your reply.

    Thread Starter mike2972


    Ah, yes that “Apply best times” box was indeed ticked. I unchecked it and saved the settings.

    I also cleared the notifications, but the list is still empty:

    The Scheduled Posts and Shared Posts pages show me some posts. With them I can click details.

    I think it’s best to wait now until the next scheduled post is published. Let’s see what happens (since I have now unticked the “Apply best times” box.

    I’ll update you after the post is published…

    And thank you again for your very quick response. It’s highly appreciated 🙂

    Plugin Support Blog2Social-Support


    Hello Mike,

    Thanks for your feedback.

    It should work immediately when sharing / scheduling a new post in your WordPress post editor after unticking the “Apply best times” box.

    Please let me know if it worked out or if you have further questions.

    Thread Starter mike2972



    Unfortunately, it does not work. A scheduled post was just published. Before it was published, I saw that the Autoposter was activated.

    After scheduled post was published, it changed to this:

    Nothing was posted on the social platforms.

    The notifications area is also empty:

    Then I opened the post editor again and clicked Customize & Schedule Social Media Posts:

    After that I clicked Share

    Now the post is indeed shared to both Facebook and Twitter.

    So manual posting to the social platforms works fine, but auto posting not.

    Any other ideas?

    • This reply was modified 4 months, 1 week ago by mike2972. Reason: Additional screenshots for clarification
    Plugin Support Blog2Social-Support


    Hello Mike,

    Thank you so much for your reply and thanks for providing these screenshots.

    There seems to be a configuration issue within your WordPress environment or in your Blog2Social settings as this behavior could not be reproduced in a neutral testing envrionment.

    Would you please be so kind as to provide us with your troubleshooting tool log file?

    The following step-by-step guide will show you how to download the log file in Blog2Social:

    How to check your blog settings with the Troubleshooting-Tool

    Please also be so kind as to check your Auto-Poster settings in Blog2Social and attach a screenshot showing your individual Auto-Poster configuration.

    The following step-by-step guide will show you how to configure and work with the Auto-Poster feature in Blog2Social:

    How do I auto-post and auto-schedule blog posts on social media with the Social Media Auto-Poster?

    Sharing with the Auto-Poster- Things to check for Troubleshooting

    It would be awesome if you could share it with us via email or via a private message in the Blog2Social support community in order to protect your privacy. To create an account and join the community go to “Blog2Social” and then “Help & Support” in your WordPress Dashboard.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.