WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Not playing well with W3 Total Cache?

[Resolved] Not playing well with W3 Total Cache?

  • I get this error on any jobs I create (even a simple optimize db job).

    [INFO] BackWPup version 3.0.5; WordPress version 3.5.1; A project of Inpsyde GmbH developed by Daniel Hüsken
    [INFO] This program comes with ABSOLUTELY NO WARRANTY. This is free software, and you are welcome to redistribute it under certain conditions.
    [INFO] BackWPup job: Test; DBCHECK+DBOPTIMIZE
    [INFO] BackWPup job started manually
    [INFO] PHP ver.: 5.3.20; apache2handler; Linux
    [INFO] Maximum script execution time is 200 seconds
    [INFO] MySQL ver.: 5.0.77-log
    [INFO] curl ver.: 7.15.5; OpenSSL/0.9.8b
    [INFO] Temp folder is: /mnt/asdf/backwpup-e22fc-temp/
    [INFO] Logfile folder is: /mnt/asdf/backwpup-74c92-logs/
    [INFO] Backup type is: archive
    [12-Mar-2013 14:16:24 America/Chicago] PHP Warning: Division by zero in /mnt/asdf/wp-content/plugins/w3-total-cache/lib/W3/PgCacheFlush.php on line 389
    [12-Mar-2013 14:16:24 America/Chicago] PHP Warning: Division by zero in /mnt/asdf/wp-content/plugins/w3-total-cache/lib/W3/PgCacheFlush.php on line 389
    [12-Mar-2013 19:16:24] DEPRECATED: Assigning the return value of new by reference is deprecated
    [12-Mar-2013 14:16:24 America/Chicago] PHP Fatal error: Class ‘BackWPup_Option’ not found in /mnt/asdf/wp-content/plugins/w3-total-cache/lib/W3/PgCacheFlush.php on line 389

    What would be the reason for this?

    Thanks!

    http://wordpress.org/extend/plugins/backwpup/

Viewing 6 replies - 1 through 6 (of 6 total)
  • We’re still seeing this error whenever we try to backup. The backup simply fails.

    Plugin Author Daniel Hüsken

    @danielhuesken

    The Plugin calls the W3TC functions to flush cache.
    What happends when you clean the cache by hand?

    Here is what I have found when both BackWPUp and W3 Total Cache are activated:

    WordPress version 3.5.1
    BackWPup version 3.0.8 Get pro.
    PHP version 5.3.13
    MySQL version 5.1.39-log
    PHP Memory limit 90M
    WP memory limit 40M
    WP Maximum memory limit 256M
    Memory in use 57.75 MB

    W3 Total Cache: v0.9.2.9

    Database only backup to a Folder – All tasks complete OK
    Database only backup to e-mail – All tasks complete OK
    Database only backup to FTP – Database dump completes OK. Archive creation completes OK. Connection to FTP server completes OK, but only part of file is transferred to the FTP server before we see:

    [17-Apr-2013 22:29:06 UTC] PHP Fatal error: Allowed memory size of 94371840 bytes exhausted (tried to allocate 445825 bytes) in /home/username/domainname.net/wp-content/plugins/w3-total-cache/lib/W3/ObjectCache.php on line 211

    I also tried to purge all caches manually immediately before running BackWPUp – same result and failure at same point.

    I have disabled W3 Total Cache for now until a workaround can be found (BackWPUp works flawlessly doing file/database backups when W3 Total Cache is not activated).

    Thank you.

    Hal

    Plugin Author Daniel Hüsken

    @danielhuesken

    Try with the WP_MAX_MEMORY_LIMIT that will used on executing jobs.

    http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    Daniel,

    Yes, it is definitely a memory issue. I removed some other plugins and re-ran my database backup job and it worked OK. The WP_MAX_MEMORY_LIMIT was already set at 256MB, but the PHP MEMORY_LIMIT is at 90MB and that seems to be the limiting factor. I cannot increase that limit in my current shared hosting environment, so I will have to figure out which plugins I can either tune or not use.

    Hal

    FWIW, W3TC has a bug right now that does not clear cache so the cache folder is HUGE. Best thing would be to exclude the W3TC cache directory all together.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Not playing well with W3 Total Cache?’ is closed to new replies.