Support » Plugin: Reduce HTTP Requests, Disable Emojis & Disable Embeds, Speedup WooCommerce » Not playing nice with Elegant theme’s divi builder

  • Resolved lesliedow

    (@lesliedow)


    HI all
    I like the plugin, but my latest release of Divi from Elegant themes is not playing nice with your plugin. I use yours to reduce query strings, but when I have that enabled in WP disable, the Divi builder thinks it’s loading a cached copy of the builder. It’s frustrating and means that I cannot use your plugin until this is addressed…by one of you. I have also been harassing the elegant themes people (who were really useless in figuring this out). Any help would be great as I would like to use your plug-in, it definitely bumped up my page speeds.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author hosting.io

    (@pigeonhut)

    will take a look, but pretty sure my response is going to be this, the plugin is doing what is intended. Query strings are used to tell the browser which version/part of the file to use, so when you remove them, it uses what it has, unfortunately in your case, it’s the wrong version of the file, hence you seeing the old cached version. This is not something we can fix as the theme would need to change the file name to a new one, instead of a css?=v4.54 or what every it’s using. I’ll close this for now, and if we can figure out a way to bypass selectively, ill post an update, for now, I’d suggest not disabling query strings, but using the other parts. BY themeselves, it should not make a major difference to page load times

    @pigeonhut perhaps it should just bypass the querystring check for logged in admins or users who can edit pages/posts.

    I submitted a PR here:
    https://github.com/hosting-io/wp-disable/pull/3

    Plugin Author hosting.io

    (@pigeonhut)

    awesome! thank you

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.