• Resolved Turn On Social

    (@turn-on-social)



    Sucuri Security v2.3

    FILE: sucuri-wp-plugin/lib/hooks.php
    ——————————————————————————————————————————————-
    FOUND 4 ERRORS AFFECTING 4 LINES
    ——————————————————————————————————————————————-
    265 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and deprecated since PHP 5.6 and removed since PHP 7.0 – use mysqli instead.
    276 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and deprecated since PHP 5.6 and removed since PHP 7.0 – use mysqli instead.
    287 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and deprecated since PHP 5.6 and removed since PHP 7.0 – use mysqli instead.
    298 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and deprecated since PHP 5.6 and removed since PHP 7.0 – use mysqli instead.
    ——————————————————————————————————————————————-

    https://wordpress.org/plugins/sucuri-scanner/

Viewing 5 replies - 1 through 5 (of 5 total)
  • The plugin definitely is PHP 7 compatible…we’re using it on a number of PHP 7 sites with zero issues. We keep WP_DEBUG enabled (in logging mode, not display mode) 24/7 and there are zero instances of this happening.

    The errors you’re seeing are database/PHP config issues. You need to make sure you have the mysqli extension installed and enabled on your server.

    If mysqli is not enabled, WordPress will fall back to the older mysql extension, but it is slower and less efficient, and is removed in PHP 7.

    What version of WordPress are you using? If you’re not on the most recent version, you should update it. I’d get in touch with your web host and get them to fix the configuration on your server.

    That’s the output from https://wordpress.org/plugins/php-compatibility-checker/ – it’s static code analysis. I’ll add you to their whitelist.

    Just FYI, I’m not affiliated with Sucuri…just another plugin developer who highly recommends the plugin.

    I’d recommend reporting that issue to the PHP Compatibility Checker devs…it seems that they are having a number of false positives for deprecated mysql.

    A plugin like that should be used carefully…basically as a pre-check to actually testing it out on a PHP 7 server with WP_DEBUG enabled. Unless a plugin actually is processing code the way PHP does, it is going to inevitably have a lot of false positives.

    Sucuri Security v2.3

    Also, are you posting this support request for the right plugin? You wrote “v2.3”, but this plugin only goes up to 1.8.1…unless I am missing something? I just grepped the plugin code and there is nothing in there that would use the mysql extension.

    Plugin Author yorman

    (@yorman)

    @turn-on-social you seem to be testing a deprecated version of the Sucuri plugin that used to be called “sucuri-wp-plugin” now it is called “sucuri-scanner”; version 2.3 was the last release we had for our premium plugin offered to our subscribed clients, and it was deprecated like two years ago.

    I used PHP7CC [1] and it reported zero incompatibilities between the current supported version of the code and PHP 7.0; the code is simple enough to run even on PHP 5.3 and I have written hundreds of unit-tests for 5.4, 5.5, and 5.6 too. I encourage you to delete the plugin that you have installed and use this one [2] instead.

    [1] https://github.com/sstalle/php7cc
    [2] https://wordpress.org/plugins/sucuri-scanner/

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Not PHP 7.0 compatible’ is closed to new replies.