Support » Installation » [Resolved] Not performing Automatic upgrade to 3.0

[Resolved] Not performing Automatic upgrade to 3.0

  • Hello,

    I just recently logged into my WordPress admin panel and noticed:

    “WordPress 3.0 is available! Please update now.

    So, I clicked that “Please update now.” link there from my panel, and then chose to do “Upgrade Automatically” as my method. when I did this, I am taken to a page titled “Upgrade WordPress”, and some text says “Downloading update from http://wordpress.org/wordpress-3.0.zip.” there on the page, but I really cannot tell if anything is actually going on at all, and nothing else ever happens.

    I have tried it both from my FireFox browser and my Internet Explorer browser, and the same thing happens on both.

    Anybody know what’s going on/what I can do? Any help would be appreciated. Thanks for reading. God bless.


Viewing 11 replies - 1 through 11 (of 11 total)
  • esmi


    Forum Moderator

    Try adding AddType x-mapp-php5 .php to the top of your WordPress .htaccess file. Then deactivate all plugins and switch to the default theme before re-running the upgrade.

    Thank you for the reply. Pardon my ignorance, but when you say add

    AddType x-mapp-php5 .php

    to the top of my WordPress .htaccess file, does that mean I can do it to the .htaccess file that’s just there on my main WordPress folder–not in any sub-folders or anything? And then also, do you mean add it before:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>

    in my .htaccess file? I have my .htaccess file opened in Notepad, and all of my code shows up in one line in Notepad. So should I just put

    AddType x-mapp-php5 .php

    Right there at the absolute beginning, even before the # ??

    Thank you again for the reply.

    Because I tried editing my .htaccess file a minute ago with your advice, and it threw off my WordPress such that it wasn’t working (then I just re-uploaded my old .htaccess file and it’s working again now).

    Let me slide in here, yess that is what he meant where it would look like this

    AddType x-mapp-php5 .php
    # BEGIN WordPress

    And of course the rest of the .htaccess information below # Begin WordPress

    Ok thanks; I will try that again this afternoon. I have tried de-activating my plugins and switching to the default theme, and that hasn’t worked. So this change to .htaccess is my my last resort. I’m gonna post again if for some reason it doesn’t work.

    Thanks, y’all.

    If none of that helps, try installing this plugin – http://wordpress.org/extend/plugins/memory-bump/

    I had a site stall like that for not having enough memory.

    Y’all are awesome.

    – Switched to default theme
    – Changed .htaccess like you said
    – Deactivated all plug-ins
    – Went to http://wordpress.org/extend/plugins/memory-bump/ , snagged it, and uploaded it
    – Activated only that Memory Bump plug-in
    Clicked “Upgrade automatically” and saw this happen on my screen before my very freakin eyes:

    Unpacking the update.

    Verifying the unpacked files…

    Installing the latest version…

    Upgrading database…

    WordPress upgraded successfully

    ^_^ Aaaaaand I’m a happy camper. Thank y’all for all of the suggestions. I knew I wanted to upgrade and get it done because I had some plug-ins I wanted to update too, and I know I need to stay current.

    I so appreciate all of the help from everyone!


    I do have one other question now, though. I am now seeing a message in my “Updates” section of my admin panel, saying:

    You have the latest version of WordPress.
    You have the latest version of WordPress. You do not need to update. However, if you want to re-install version 3.0, you can do so automatically or download the package and re-install manually:

    Should I re-install right now? What are reasons to do it and not do it?

    Thanks for any insight anyone can give.


    Thanks to you all. I was pulling my hair out and now all my sites are upgraded. 🙂

    This is now happening again, as I am trying to update a plug-in. Just stalls and does nothing. I’m about to try all of these things again and see if it works again..

    Never mind. Just did same method again, and all is fine–got it to version 3.0.1 this afternoon~

    Thanks again!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Not performing Automatic upgrade to 3.0’ is closed to new replies.