Support » Plugin: Optin Forms » Not passing the name to the mailchimp form

  • Resolved Doug M

    (@nes-native-english-services)



    I sent a tweet to you about this hoping you might respond a little faster 😉

    I’ve got the form set up and for some reason it’s not passing the name to MC…I’m getting sent to an MC error page asking me to enter the name.

    https://interstellarengland.co.uk

    Thanks.
    Also, I wanted to checkout the pro version but the site it’s linked, https://optinlock.com, to is dead. Getting a can’t be reached notice.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author FancyThemes

    (@fancythemes)

    Hi,

    On that coming soon page you have I tried the form and got a “Server Error” response. But when I checked the source code I noticed it isn’t OptinForms, it’s Elementor page builder.

    I’m assuming you switched due to the issue, but seems you’re getting an issue with the replacement as well, so there’s a chance the issue is not related to the plugins but to the server.

    Doug M

    (@nes-native-english-services)

    Sorry about that… I turned back on the coming soon page and yes it is using the Elementor form. I wasn’t aware it was not working as I switched back over right before I went to bed, so thank you for that but now I’m back working on the site.

    You can see it here.
    https://interstellarengland.co.uk/ajuga-turkestanica-turkesterone/

    Thank you

    Plugin Author FancyThemes

    (@fancythemes)

    Hi Doug,

    I tested on my server with my MailChimp form and did not get any issues. Then I tested it on my server but with the same URL you are using and I did get the issue.

    I checked the form data that Mailchimp was getting and the name was in there. So it’s a bit weird.

    Can you u try this, go to MailChimp > Lists > Signup Forms > Embedded Forms. Choose “Naked” and copy/paste the code from there anywhere on the site and try it out.

    If the same issue happens then there’s some issue with Mailchimp or settings that you have, you’ll need to contact them. If the issue does not happen, let me know so we can investigate further.

    Doug M

    (@nes-native-english-services)

    Just tried the bare link in the url bar and it works

    https://interstellarengland.us7.list-manage.com/subscribe/post?u=f98f4d395d6eb7d3008b59d37&id=92ec7cd5ac

    I tried embedding it on a page and get just the link…not a form of any kind
    https://interstellarengland.co.uk/test

    I’ve got about 30 minutes before I have to leave…if you aren’t doing anything at the moment.

    Thanks

    Plugin Author FancyThemes

    (@fancythemes)

    Hi,

    There was a misunderstanding. Don’t just put that URL on a page, put the whole form code from Mailchimp.

    Go to WP Admin > OptinForms. Click on that (?) icon which show how to get the URL.

    But on the last step, instead of getting the “form action url”, copy the entire thing ( the whole code ) and paste it on a new page.

    Doug M

    (@nes-native-english-services)

    When I do this…the page works….

    https://interstellarengland.co.uk/test/

    Thanks for the help.

    Doug M

    (@nes-native-english-services)

    I just did a real quick screencast for you…so you can see exactly what I’m doing in case I’m missing something simple.

    http://somup.com/cbi0XKV6ll

    Plugin Author FancyThemes

    (@fancythemes)

    Hi Doug,

    I noticed that the field name on the ( https://interstellarengland.co.uk/test/ ) is MMERGE1 and the one from the plugin is called FNAME which is why MailChimp is not recognizing it, it’s expecting MMERGE1.

    1. Head over to mailchimp.com and log in to your account.
    2. Go to Lists.
    3. Click the “downward angle icon” ( at the very right of the list item ) for more options and click on “Settings”.
    4. Click “List fields and *|MERGE|* tags”

    This is a screenshot of what you should have there, if you have different settings change to be like the ones in the screenshot.

    You can click on it for the full resolution

    Doug M

    (@nes-native-english-services)

    Thank you…not sure how that happened but ran into another issue. Here’s a 1 minute screencast of the conflict with ElementorPro forms.

    http://somup.com/cbiT6QV6Zl

    Thank you again.

    Plugin Author FancyThemes

    (@fancythemes)

    Hi,

    Gave it a quick test with Elementor Pro but I’m not getting the issue. Can you please save that page as an Elementor template, export it and send over the export file.

    That way I’ll have the exact same setup as you and should see the issue and figure out what’s causing it.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Not passing the name to the mailchimp form’ is closed to new replies.