• Resolved wp-MeMeMe

    (@wp-mememe)


    I’m having an issue with this plugin installed. If I try to edit a page, I’m told that post is not part of a series, and none of the series I have created are shown. It is an empty list.

    If I roll the plugin back to version 2.5.13 ot works again, but no version between that and the present version works properly. (I believe the current version is 2.11.4)

    For the record I have been using this plugin for a couple of years, and definitely through the versions 2.5 to 2.11, and the issue has just appeared. I’m guessing its related to the series numbering fixes mentioned in the latest versions log.

    • This topic was modified 8 months ago by wp-MeMeMe.
    • This topic was modified 8 months ago by wp-MeMeMe.
Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Olawale Adesina

    (@olatechpro)

    Hello @wp-mememe

    After upgrading the plugin, you should get a notification below on admin pages for data upgrade.

    Can you confirm if you completed the upgrade task?

    Thread Starter wp-MeMeMe

    (@wp-mememe)

    I did see that a few days ago, and completed it. The plugin worked normally afterwards. But this morning, the problem appeared.

    Is there a way to trigger that again? The series data is being recognised in older versions of the plugin, so has that upgrade been undone somehow?

    • This reply was modified 8 months ago by wp-MeMeMe.
    Plugin Author Olawale Adesina

    (@olatechpro)

    @wp-mememe

    If you go to Manage Series > Series Order for your series, can you see any posts in the list or the list is empty for all your series?

    Plugin Author Olawale Adesina

    (@olatechpro)

    Also, if the upgrade was completed successfully, older version of the plugin will no longer show the correct part but if it does, that shows the upgrade wasn’t completed successfully.

    So, we’ll need to make an update that enable manual trigger for series update to new part and I’ve added an issue on it in https://github.com/publishpress/publishpress-series/issues/810.

    I’ll try my best to work on this today and send an update for test.It’s advisable not to

    Thread Starter wp-MeMeMe

    (@wp-mememe)

    With the current version restored, when I go to the Manage series, it does show posts for series. But when I click on the latest series, it doesn’t show all the posts – the most recent posts aren’t there.

    (I’m guessing it is only showing posts whose order was managed before the upgrade.)

    When I look at the posts in the Add post window, they are shown as added to the series, with no post number.

    Then when I edit the post, they are shown as “not part of a series”.

    • This reply was modified 8 months ago by wp-MeMeMe.
    Thread Starter wp-MeMeMe

    (@wp-mememe)

    Your last post says “It is advisable not to” and then ends. What is it advisiable not to do?

    Thread Starter wp-MeMeMe

    (@wp-mememe)

    Interestingly: when I have the latest version of the plugin, it says “No part number” for those posts, but when I roll back to 2.5.13, it correctly shows the part numbers I have manually set.

    • This reply was modified 8 months ago by wp-MeMeMe.
    Plugin Author Steve Burge

    (@stevejburge)

    Hi @wp-mememe. The latest version involved a small data migration. It looks like it didn’t run for you.

    @olatechpro is saying that he’ll add a button so you can run that migration on your site.

    Plugin Author Olawale Adesina

    (@olatechpro)

    Hello @wp-mememe

    Here’s an update made for you to run the migration manually https://drive.google.com/file/d/1zj0uEGrSLnui9NJSYtvq16S6hh55CKA5/view?usp=sharing

    After installing the upgrade, Go to Series Settings > Advanced tab to run the migration.

    Kindly keep me updated if that fixes the issue or not.

    Thread Starter wp-MeMeMe

    (@wp-mememe)

    Sadly, no change.

    I see the Upate task button, and click it, and the page reloads as if it has done something.

    But when I open the edit for a post this is part of a series, this is what I see

    View post on imgur.com

    Exactly the same as before.

    Plugin Author Olawale Adesina

    (@olatechpro)

    @wp-mememe Did you get this message after running the upgrade?

    Thread Starter wp-MeMeMe

    (@wp-mememe)

    No, I didn’t get any update or message that the process had completed.

    Plugin Author Olawale Adesina

    (@olatechpro)

    @wp-mememe

    I think you may be having capabilities issue.

    1. Confirm if  manage publishpress series is enabled for your role as shown in the below screenshot
    2. Can you install https://wordpress.org/plugins/capability-manager-enhanced/
    Thread Starter wp-MeMeMe

    (@wp-mememe)

    Can you be more specific how to get to that screen? I have Capabilities installed, and I see a lot of entries that I don’t understand, but I don’t see publishpress series anywhere.

    I’m the creator and maintainer of the website, btw, and the only person who has done any editing at all. I havent had any issue installing other plugins, so there shouldn’t be an issue here.

    • This reply was modified 8 months ago by wp-MeMeMe.
    • This reply was modified 8 months ago by wp-MeMeMe.
    • This reply was modified 8 months ago by wp-MeMeMe.
    Thread Starter wp-MeMeMe

    (@wp-mememe)

    Edit: for anyone who saw the original post that used to be here. It was an ID 10 T error – a syntax issue with a different plugin.

    • This reply was modified 8 months ago by wp-MeMeMe.
    • This reply was modified 8 months ago by wp-MeMeMe.
    • This reply was modified 8 months ago by wp-MeMeMe.
Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Not Part Of A Series’ is closed to new replies.