Support » Plugins and Hacks » [Resolved] Not loading images from specific album

[Resolved] Not loading images from specific album

  • Hi,

    I’ve noticed that I can’t get the plugin to display Picassa albums. I’m using WordPress 3.5 with 1.42.

    Here’s the shortcode;

    [gallery type='picasa' user_id='110790727409294830892' kind='photo' album='5836567326041637025' thumbsize='140']

    I also tried using kind='album' but neither work. I also tried using the integration with the media library but that didn’t work either… in both instances I see the following in my HTML;

    <div id="photonic-picasa-stream-1" class="photonic-picasa-stream photonic-stream"></div>

    Strangely, if I leave out the album parameter to show all albums in album view, it works.



Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Sayontan Sinha


    Your album id is wrong. Google+ ids are different from PicasaWeb ids (and Google doesn’t offer me any way to swap the two if you provide one – the two APIs are different). Typically to find the PicasaWeb id you have to log into http://picasaweb.google.com and hover over an album name. You will see this format: https://picasaweb.google.com/110790727409294830892/YourAlbumID. Pick the album ID from here.

    Bear in mind that this is a Picasa plugin, not a Google+ plugin – I would have supported both, but Google doesn’t offer a Google+ API to manipulate images, and the Google+ API is different from the Picasa API.

    Hi Sayontan,

    Thanks for this… solved my problem.

    The ‘Photos’ feature with Google Plus has become a much more intuitive platform for maintaining images for my clients who use it alongside other Google services (Gmail/Analytics/Docs/Calendar etc.)

    It’s a shame Google didn’t use the same key across both APIs given they use the same images.


Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Not loading images from specific album’ is closed to new replies.