WordPress.org

Forums

Promotion Slider
[resolved] not loading correctly after updating the plugin (12 posts)

  1. gail
    Member
    Posted 1 year ago #

    I updated the plugin yesterday, and now when loading/refreshing the page, the 4 featured images in the homepage promotion are visible horizontally down the page. They go away after a couple seconds.

    However, the images are there permanently when viewing the page from mobile browsers.

    http://wordpress.org/plugins/promotion-slider/

  2. gail
    Member
    Posted 1 year ago #

    I've removed 3 of the 4 slides because they were all showing horizontally on the page, overlaying the other content.

  3. Micah Wood
    Member
    Plugin Author

    Posted 1 year ago #

    @gail,

    If you can provide a link to the page where this is happening, I would be glad to take a look.

  4. HenrikErlandsson
    Member
    Posted 1 year ago #

    Same here for http://extend.se/version2/

    It says version "3.3.4" in the Edit plugins "Editing promotion-slider/index.php (active)" window. It says src="http://extend.se/version2/wp-content/plugins/promotion-slider/js/promoslider.js?ver=3.5.1" in html head, if that's relevant.

    JQuery 1.8.3, if that's relevant.

    The new site is installed in a subfolder, /version2/. Is that the reason for seeing 3.3.4 in the Edit Plugins window? If so, how do I correctly install it so it's found correctly?

    Hope this information helps.

  5. HenrikErlandsson
    Member
    Posted 1 year ago #

    Strangely, it adds a note under that script tag: "Reload the page to get source for: http://extend.se/version2/wp-content/plugins/promotion-slider/js/promoslider.js?ver=3.5.1"

  6. HenrikErlandsson
    Member
    Posted 1 year ago #

    Ah, for some reason the folders and files get the wrong permissions when you copy a site and update using the built in WP plugin updater. (Got 403 error on the JS link above). The js folder had 710 and index.php had 640. Setting folders to 755 and files to 644 fixed it. (Please let me know if these are unsafe for plugins!)

    The slider didn't fit in the splash container anymore and we had to adjust the paging div, but that might be the CSS of the customer causing that.

  7. Micah Wood
    Member
    Plugin Author

    Posted 1 year ago #

    @HenrikErlandsson,

    I'm not sure what to make of the above. I see two sites, both running older versions and working fine.

  8. gail
    Member
    Posted 1 year ago #

    @micah -- Thanks so much for responding.

    The site is: http://www.21stcenturydems.org/

    I have only one slide up now, but this is what it looks like with more than one: http://www.21stcenturydems.org/wp-content/uploads/2013/10/Capture.gif

  9. Micah Wood
    Member
    Plugin Author

    Posted 1 year ago #

    @gail,

    It appears as though you are using cloudflare and the Javascript and CSS is being combined / minified. After a quick search through your existing Javascript and CSS files, I didn't see anything related to the Promotion Slider. Probably just a simple issue of actually loading the Javascript and CSS files.

  10. gail
    Member
    Posted 1 year ago #

    Thanks very much. Will work on that.

  11. HenrikErlandsson
    Member
    Posted 1 year ago #

    @Micah, well I fixed the problem yesterday, so naturally both of them work. Can't have non-working sites online. The below page says the latest version is 3.3.4. Is it? If the plugin editor says 3.3.4 in the source and I still have an old plugin, then I don't know how to check the version.

    http://wordpress.org/plugins/promotion-slider/changelog/

  12. Micah Wood
    Member
    Plugin Author

    Posted 1 year ago #

    @HenrikErlandsson,

    My bad. That is the latest version.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Promotion Slider
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic