WordPress.org

Support

Support » Plugins and Hacks » Business Directory Plugin » [Resolved] Not installing tables in version 3.0.1

[Resolved] Not installing tables in version 3.0.1

  • I just tried to update to v 3.0.1 but it couldn’t get rid of the older version, so I disabled the plugin and uninstalled it, then I installed the update, but in the frontend when I tried to insert an ad it was just looping, really funny, it just kept looping, I couldn’t find the form, so I decided to uninstall the plugin and manually delete the database tables, now when I try to install the newer version, it just won’t install any db table, but the backend is working fine.

    http://wordpress.org/extend/plugins/business-directory-plugin/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author businessdirectoryplugin

    @businessdirectoryplugin

    Hi spike,

    Hmmm…that’s not what I would expect. Can you tell me?

    – Version of WP?
    – Version of PHP?
    – Version of MySQL?

    And can we get access to your site to look at this issue directly? Please drop me a line via the contact form: http://businessdirectoryplugin.com/contact/ I’ll need admin and FTP credentials to view it.

    WP 3.5.1

    PHP 5.4.4

    MYSQL 5.5.25a

    I’m working in local host.

    Sorry, this is not resolved, I dont know what to do..

    Plugin Author businessdirectoryplugin

    @businessdirectoryplugin

    Hi Spike,

    My developer had this to say about it:


    I don’t know what the user means by “looping” exactly but it might be the case that he was affected by the 3.0 upgrade bug so the fields didn’t appear.
    Now, he deleted the tables manually, but we keep a special flag inside WP that indicates the current version of our tables in the database. Since he last installed 3.0, this is what the variable says so our plugin thinks the tables are in place when in fact he removed them all.

    If he has access to the database (like it seems to be the case) he can look for a row inside the wp_options table that has option_name equal to wpbdp-db-version. He can just remove this row and the plugin will install the tables again automatically. He doesn’t even have to delete it or deactivate it. It will do this during a regular page load.

    Yeah, now I got all tables back, I just have to test the website now. I’ll open another support question, but it won’t be a question it will be something that will interest both of you.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Not installing tables in version 3.0.1’ is closed to new replies.
Skip to toolbar